The revisions let you track differences between multiple versions of a post.

Revision of Patch 3.1.0 Addon Update from Wed, 2009-04-15 21:15

Jiyambi's picture

Update! Tour Guide new version available here, TomTom still not updated. I'll post as soon as more is known.

Thank you everyone for being patient, I know it's very annoying not to be able to use the guides! Also, thanks to those who have helped by posting update links and temporary fixes.

It looks like Cartographer *might* have a working update, but it may still have some bugs as well. Cartographer is a somewhat bulky map addon that provides an arrow just like TomTom's, so if you folks are desperate to get it working again, this is an option. The newest version can be downloaded here.

From Maw:

    As TomTom is not working, a thing you could do is to enable "waypoints" in the Cartographer menu. Then that waypoint function will make waypoint for you everytime a new coordinate appears in the guide. A red cross will also be shown at the map at the named location. You can also simply type /way xx,yy when you come to a new step and a new coordinate is mentioned in the guide, and then a waypoint will appear, though no red cross on the map.

There may also be a TomTom beta floating around somewhere, I'll try to get the link for you ASAP.

Comments

Having an issue

Okay so recently I've been running into an issue. I can load the wow-pro guides perfectly fine on my alt mage on my main server, but recently I created a horde toon on another server and for whatever reason it won't load the wow-pro guides. It only happens on that char, and I would really appreciate some help with this =)

Thank you

Jiyambi's picture

If your mains are alliance,

If your mains are alliance, that means you don't have the Horde version installed - there are two separate versions of the guide, one for Horde and one for Alliance.

If that's not the problem, then check and makes sure that on the new server, you have "Load out of date addons" enabled, I think it could be different preferences for different servers.

Wow, /facepalm. I can't

Wow, /facepalm. I can't believe the solution was that simple. I seemed to have forgotten where it said Wow_pro_ALLIANCE! hah, thank you so much Smiling

Jiyambi's picture

Haha, no prob glad it was

Haha, no prob Eye glad it was an easy fix.

Hellfire Horde Guide

Hi.
First i would like to congratulate James for these fabulous guides. Leveled a couple of chars using them already and is swift.

I'm leveling a DK now, so i decided to guive the addon a shot. Started doing the Hellfire guide, and it was all smooth until i fly to spinebreaker post.
After delivering the quest, the guide gives me no more indications about the quests. It just contains the indications of the zones i should go to next.
Not shure if that's intended, or if the guide is unfinished, or perhaps something broken.

Jiyambi's picture

Sounds like something funky

Sounds like something funky with the DK guide in particular, I'll check it out.

bazza's picture

patch

hi there sorry bout my spelling but hear goes when i update the latest patch it runs to 70 % the disappears so i can play anymore plz some help me many thank bazza

JamesL85's picture

More Info

OK, what is it you're updating? Are you downloading the mod from this site or when you're trying to download the 3.1.1 patch from Blizzard?

James

I have updated all the

I have updated all the addons to the most current ones and now I can't get any guides to load or Tom Tom to work. I get this error message "Interface\AddOns\TourGuide\Parser.lua:88: attempt to call field '?' (a nil value)". Anybody know how to fix this problem?

Odd Problem...

When I load the Tourguide addon and the Alliance Guide at the same time, the Tourguide itself disappears, and so does the green arrow. When I load only the Tourguide, it shows up but obviously is pointless since I cant use the guide.

I deleted the old versions of Tourguide, TomTom, and Lightheaded, then re-installed the new ones, so I have no idea whats going on.

Jiyambi's picture

That is a very odd problem.

That is a very odd problem. Try opening the Tour Guide options under your interface options (use escape to get there). There should be a way to reset it to the default position, this might help. Otherwise, I'm out of ideas Sad

Quest item buttons

The guides load up fine for me, but i have another problem. When i try to press the button for the active quest's item, nothing happens. This is ofc a small thing, but i really liked that i never needed to look in my bags for a quest item..

Jiyambi's picture

Blizzard broke this

Blizzard broke this functionality when they added their own version of it. Your in game quest trackers should now have item buttons on it. You can also move the in game quest tracker around. The options are in your interface options menu somewhere.

EDIT: Drat, Sixtel got to this before me! >_< Eye

Sixtel's picture

Blizz's new quest button

Blizz now has a quest button to. Mine was hidden under one of my bars. This button worked for me and the old button no longer worked.

"No one impedes us...no one denies us....and if need be....no one survives us...,"

Edit:Yes but you phrased it better than me Smiling

"No one impedes us...no one denies us....and if need be....no one survives us...,"

I found it, thanks guys.

I found it, thanks guys.

ARRRRGHHHH.....

OK, I have

1. Deleted the old Tour Guide and downloaded the newest one available

2. Deleted TomTom and downloaded the newest one available

3. Deleted Lightheaded and downloaded the newest one available

I have not seen a new Wow-pro guide to download for 3.1. The latest Wow-pro leveling guide that I have still shows as out of date in my add-ons screen. I tell the game to load it anyway. Tour Guide does NOT list and Wow-pro guides, neither in the interface tab under guides, nor when I right click the small tour guide HUD and select guides.

Please help, because I've been doing my best to bug-test the latest version, but I WANT TO PLAY MY TOON!!!! Smiling

Jiyambi's picture

Hmmm, the guides should load

Hmmm, the guides should load based on what you've said. I've done the same things, and my WoW-Pro guides are loading fine. I'm on the Horde side. And I think I've heard it working for people on the Alliance side as well.

I just don't know what else to have you trouble-shoot from here, perhaps Jahwo can provide some insight.

Uninstalled and re-installed

Uninstalled and re-installed again, finally got it to work, although it still lists as oudated. Back to the bug submissions!

Jiyambi's picture

Yay! Unfortunately it will

Yay! Unfortunately it will be listed as outdated until we get an update from someone who knows more about Lua than I (probably Jahwo), but it should work fine despite that. Thanks for all the hard work, we really appreciate testers!

From the Alliance

Yes, it works for Alliance Guides as well, albeit with some strange behavior in TG. Bothing breaking though.

My suggestion is to delete your WTF file after backing it up, then make sure that your config file was deleted as well.

If that doesn't work, and you are running Vista, make sure you have UAC turned off, install the addins to c:.../Username/Public/Games/World of Warcraft... etc. as WOW now draws from a different location in Vista.

Jiyambi's picture

Great troubleshooting ideas,

Great troubleshooting ideas, thanks!

A Huge Thanks

Thanks a lot! I can't live without them!

RazmaX's picture

I downloaded the new version

I downloaded the new version of Tourguide but for some reaon I can't get the wow-pro guides to load its still telling me they are out of date. Any fix for this? I did download them again that didn't seem to help.

At the character selection

At the character selection screen, there is a button in the lower left-hand corner labeled "Addons". Click it. There will be a screen that displays showing you a list of all your addons (and which ones are out of date). Select the checkbox at the top that says "Load Out-of-date Addons".

You can do that for all of your characters individually, or all at once in that screen.

RazmaX's picture

Thanks

Thanks

Woo Hoo!

Oh man I can't live without these guides I'm so glad they're back up. Woo Hoo~!

Used the above download links but my version says v3.09.48

Downloaded the above version of TourGuide but it still says v 3.09.48 when I check it. I even deleted the previous TourGuide folder and tried reinstalling from the above link.

When I load WoW, I get an error saying:

Message: ..\AddOns\TourGuide\Broker.lua line 70:
attempt to call global 'QuestWatch_Update' (a nil value)

Message: ..\AddOns\TourGuide\Parser.lua line 81:
attempt to perform arithmetic on field 'current' (a nil value)

Not sure what I'm doing wrong! I even disabled every other addon besides tourguide but no luck. Anyone got any ideas?

Jiyambi's picture

Hmmm, I know the above link

Hmmm, I know the above link works, and at least according to the change log, it is version 3.1. What operating system are you using?

Fixed. Apparently Windows

Fixed. Apparently Windows Vista does not like to play nice. I finally moved my WoW folder to Public

And how do u do

And how do u do that?
Because i got the same problem Sad
And also i'm using Xperl and i can't Rightclick on the target's Lifebar/Mana So i Can't trade or inspect or whatever Sad

Jiyambi's picture

For moving the WoW folder,

For moving the WoW folder, Im not 100% if you can just move it, I think WoW asked me to do it at some point and I just clicked "OK".

The XPerl problem has been fixed in the most recent update (I use it as well), go to Curse and download the newest one to fix it.

Moving the WoW folder

I just copied mine from Program Files. I went to Users\Public and then created a folder called Games. Then copied and pasted the World of Warcraft folder over.

so, you should get be in C:\Users\Public\Games\World of Warcraft

I left the old one in the Program Files just in case but it worked perfectly. Only problem is that I had to redo my interface.

Jiyambi's picture

HAH! That was exactly what I

HAH! That was exactly what I thought it was Smiling Ignore my above post, you responded while I was typing.

Arannar's picture

Wowinterface is now working

Wowinterface is now working properaly and I was able to download the new version of Tom Tom, I can confirm that it is now working properly, so you all can get back to your questing (Yay!).

Interface maybe working but...

Interface maybe working but I have downloaded the new TomTom and I can't find my green arrow anywhere. I took out all the other TomTom folders and have just the r199. Unzipped, installed but can't find an arrow. Please tell me what I did wrong,lol.

Thanks

Arannar's picture

I really have no clue what's

I really have no clue what's wrong, but try this: Open up the folder where your addons are stored, look for "TomTom" delete it, and the .rar file that you extrated it from. Go to www.wowinterface.com and look for their list of updated addons, Jiyambi has a link on the front page download it, extract, you should have TomTom-rrsomthing as the title double-click that and you'll see a folder that says "TomTom"
right-click it and choose "cut", then go to the folder hwre your addons are stored and paste it. If that doesn't work then you'll just have to rely on Cartographer, sorry if this wasn't of any help to you.

OMG I LOVE YOU, lol

Thank you so so so very much Arannar!! It fixed it and now I'm soooooooooooo Happy. Thanks again Laughing out loud :D Laughing out loud

Where did u find ur

Where did u find ur Addons?
In the progam WoWMatrix itself?
Pff im lvl 79 and i can't get 80 without TomTom
Arghhh!

Jiyambi's picture

Heh, another reason why

Heh, another reason why WoWmatrix = fail!

Where your addons are depends on what operating system you use. Check the installation section of this page for the location of your addons, I don't feel like typing it all out again. I will eventually get a FAQ up that shows this.

Arannar's picture

I agree WoWMatrix is soo

I agree WoWMatrix is soo fail Sticking out tongue

Jiyambi's picture

Hmmm, I don't use TomTom so

Hmmm, I don't use TomTom so I'm not sure, but I know the newest version of Cartographer is definitely working with our guide, so you could try that if you really want to.

Maw's picture

As TomTom is not working, a

As TomTom is not working, a thing you could do is to enable "waypoints" in the Cartographer menu. Then that waypoint function will make waypoint for you everytime a new coordinate appears in the guide. A red cross will also be shown at the map at the named location. You can also simply type /way xx,yy when you come to a new step and a new coordinate is mentioned in the guide, and then a waypoint will appear, though no red cross on the map.

This is a temporary solution which, atleast for me, works perfectly fine with Joana's In-Game leveling guide. I'm not completely sure if this'll work with TourGuide, but I think so.

Hope this helps to someone that wishes to level on even under these rare conditions.

EDIT: Make sure to have TomTom disabled when doing this.

EDIT 2: Noticed after writing this that Jiyambi has already said some of this, if she didn't add it (really fast) after I wrote this Sticking out tongue

Kuismar's picture

Or download the TomTom Beta

Or download the TomTom Beta from WoWInterface. This was the version he was making on the PTR. From what I've read its functional.

-----
all i want in life is to be happy!

All I Want In Life Is To Be Happy!!! - Korn

Jiyambi's picture

I've been trying to get onto

I've been trying to get onto WoWInterface all morning and getting lots and lots of server errors. I think they might be experiencing too much traffic with the patch issues going on.

If you have a link for it, let me know, otherwise we'll have to wait until I can get on there and find it >_<

EDIT: Nvm, got onto the page shortly after posting this.

Mmadvo's picture

.........basterd

.........basterd wildhammer

tourguide has been updated i use it now as we speak but i havent seen teh new update for tomtom yet keep up the good work jame

.........basterd wildhammer

Differences between TG and the regular guides

I have used Jame's guides to level a number of toons. I have now tried the new add on version.

First of all, the sequence of quests is not the same. In some cases, it is more efficient, in others less.

For example, in the original allie guide for the Borean Tundra, you suggest jumping down the hole to get the escort quest. In the addon, you do the escort after getting the quest to kill the guy in the lake. This is an improvement.

On the other hand the series of quests with the bots and the pumping station is not as well done as in the original written guide.

This is just a comment. Thanks for the great work on both formats.

Mavet, 80 DK on Boulderfist

Mavet, 80 DK on Boulderfist

Jiyambi's picture

Admittedly I haven't played

Admittedly I haven't played that particular portion of the addon guide, but are you sure you are using the WoW-Pro guide and not the default TourGuide guide?

TourGuide 3.1.0 Fix

If you're feeling adventurous, you can update TourGuide yourself:
1) Go to Start -> All Programs -> Accessories -> Notepad.
2) Open "C:\Program Files\World of Warcraft\Interface\AddOns\TourGuide\Broker.lua". (You may have to change "Text Documents (*.txt)" to "All files (*.*)".)
3) In the middle of the file, change "QuestWatch_Update()" to "WatchFrame_Update()".
4) Save. Then reopen WoW (if it's already open, type /reloadui).

Tekkub said he's already made the change and will release a new version of TourGuide shortly.

It works great but

It works great but I can't seem to get TomTom arrow thing to work. I have tried all the obvious stuff but its not working. Any tips on how to fix this as I find it very helpful/important whilst leveling.

Thank you very much for all the info so far. Smiling

About the Update Instructions

I attempted to do the update and somehow, i'm not entirely sure, i managed to screw it up >.< Jawdropping!

Crossing the distance from here to there and back again