WoW Beta Report v6.0.2 (18764)

Ludovicus's picture

So Emmaleah and I have been busy for the past few days.  She's been making changes to the guides and I have been fixing bugs in the Addon.

While I had great plans at makes some updates to the Pandaria addon, Verizon decided to break my DSL connection for most of the weekend, so I had to put that part off.

So new features and fixes:

  1. We now  support a tag to detect garrison buildings.  |BUILDING|Lumberyard;40| will detect a level 1 Lumberyard and will send you on your quest for your first timber.
  2. Tags of the form |QO|1|  now show the quest objective in text form (oops!)
  3. The code for dealing with missing M tags now works for WoD
  4. The quest objective tracking now works for WoD.
  5. Now using QUEST_TURNED_IN and QUEST_ACCEPTED monitoring internally to see how well Blizzard implemented them. 
  6. Changed the mapping system for both the Pandaria and Dranor addinds to use a ordered list of functions so we can do manual updates semiautomativcally. 
  7. Added Frostwall, Warspear tons of other new WoD zones.
  8. Lots of changes to the recorder to make Emmaleah less annoyed at it.   Still needs more TLC.

 

Anyways, we are getting close to the point where we could use some help writing guides.    I'll draft a list and ask for volunteers.

All of addons necessary for survival mostly work!

Comments

Professions working?

I have the following showing on step with a profession tag even though all characters tested with have various professions.

82: NextStep(): Permanently skipping step because player does not have a profession.

Ludovicus's picture

Re: Professions working?

Well they *were* working.

I'll check them out on the PTR.

Emmaleah's picture

working when I made Frostfire

I know they were working in August when I was doing the Frostfire guide.

Emmaleah == bravely leading the way since ... um a long time ago... Smiling

Is Flight Master detection

Is Flight Master detection working, as it seems to not work for me anymore.

Is there a |Z| that would work for the garrison?

Also, I find that with the Recorder component enabled, the guide goes straight to the last entry, rather than the current entry.

Ludovicus's picture

Re: Is Flight Master detection

Flight point detection is working, as long as you have spoken to a flight master in the contininent at least once.

The |Z| for the garrison is |Frostwall|.

There are four big bugs with the recorder:

 

  1.  Currently active quests can get inserted at the start of the guide when zoning or hearthing
  2. Various conditions can cause a guide to be "lost" or "reset"
  3. The active step is always at the end "insertion" point.
  4. The step navigation menu does not work.

Re: Waypoint Wrong Zone

Is |Frostwall| also for Alliance, as it doesn't work. Possibly it should be Lunarfall, but that doesn't seem to work either (Step ### has bad Z|Lunarfall tag)

Flightpoints, ignore, it's just me, I can't tell the difference between F and f !!!

TomTom's generating an error everytime I change zones: Interface\AddOns\TomTom\libs\Astrolabe\Astrolabe.lua:1236: attempt to perform arithmetic on local 'TLx' (a nil value)

Loading generates LibMapData-1.0 errors for area id and missing data for BlastedLands, Hyjal, TwilightHighlands, and Bad GuideLevels for BitAra2025 and EmmFrostfire.

The guide has WoWPro:GuideNextGuide(guide, 'ShadowDraenor|EmmFrostfire'), I have a file with
- local guide = WoWPro:RegisterGuide('ShadowDraenor'
and one with
- local guide = WoWPro:RegisterGuide('EmmFrostfire'
After completing the guide, I get a chat message:
- WoWPro: Switching to next guide: ShadowDraenor|EmmFrostfire
However no guide is loaded (No Guide Loaded. Right-click the guide header and select "Guide List" to choose a guide.)

Ludovicus's picture

Re: Waypoint Wrong Zone

Oh, Frostwall is the Horde specific zone in Frostfire ridge.

The correct zone is Lunarfall (in Shadowmoon), but the current zones files is missing both Frostwall *and* Lunarfall.

Since the server crashed shortly after I collected the information, it may be possible it was feeding me a pack of lies.

I am going to re-genenrate the maps and see if I can get something more consistent.

The GuideNextGuide is a bug, but I think in the guide.  If you were alliance, there is no such guide written yet :-).

The Astrolabe error is my fault as well.   But it is a quick fix.

Gimme an hour at most.

 

Ludovicus's picture

Re: Re: Waypoint Wrong Zone

This is sooo messed up.   Until you unlock the garrisons, the game will now not give you information about the zones.

That is why Frostwall and Lunarfall went away.   I scanned on a toon that had not done the quests yet.

Furthermore the map name for Frostwall makes me think that the map CHANGES when you upgrade you garrison.

Anyways, Fluclo, if you can tell me what the map id is for Lunarfall, I will add it in by hand for now.

I need to take a nap.

Garrison Map Changes

Yes, the map does change depending on your level of progression.
For Lunarfall, the first map comes when you've spoken to Baros Alexston in the quest Establish Your Garrison, the other two comes when you upgrade your garrison to level 2 and level 3. 

Biggest pain-point with the garrison is when you've upgraded to Level 2, it's hard to get back to the shore, you have to run south to go north. Why oh why didn't my builders keep that path to the north-west going?

Lunarfall appears to be 971

Lunarfall appears to be 971 (and when I add that to WoWPro Zones, the coords for the garrison works :) )

Ludovicus's picture

Re: Lunarfall appears to be 971

OK.  I am  going to have a "manual exceptions" part to the zones file.

I am hoping that the map number remained constant, while the map ID stays constant.

I'm 99% sure about that when I upgraded my last garrison.     I've had to delete my toons so many times, I'm getting dizzy.

Tanaan Jungle

Can't get the waypoint to work in Tanaan Jungle (the initial Assault on Dark Portal zone), any suggestions? There's no errors, but it just doesn't display the waypoint arrow in Tanaan Jungle (works fine in Shadowmoon Valley, and in Stormwind, but not Tanaan Jungle)

Ludovicus's picture

Re: Tanaan Jungle

Hmm, it *used* to work.   I'll take a quick look.

Emmaleah's picture

Tanaan Jungle Waypoints

Well, part of the problem is that it thinks its zone 970 (Eastern Kingdoms)

Its 945 when you first come thru the dark portal and somewehre about the bottom of the steps the map is reading 970 instead.

You can manually make the arrow show up by typing /way x y.  but, when you cross that "point" the arrow goes away.  The green dot however remains.

If you remove the waypoint, you can type /way x y and the arrow (along with the waypoint) will reappear

if you do not remove the waypoint, the arrow will not reappear.

Emmaleah == bravely leading the way since ... um a long time ago... Smiling