WoW-Pro 6.0.0E Leveling, Dailies, WorldEvents, Achievements and Professions Release Notes

Ludovicus_Maior's picture





Current Version: 6.0.0E
Last Update: Oct 21, 2014
Next Update: Oct 22, 2014



This update includes:
  • Wrath of Draenor Support
  • Updates to *all* the older guides.
  • Updates, as we incorporate the suggestions and bug fixes from YOU, our community! There are > 183 guides, of which some guides had updates.
  • A promise to update the guides semi-monthly.
  • A various bug fixes.

We will make new releases as people find bugs, but no more often than once a day for the first week or so.

The updated guides include:

  1. Will be filled in later.

We have some fixes/enhancements this update:

We have 2 known bugs this release:

  1. Guide chooser is incomplete
  2. Trying to check off steps seems unreliable.

While the current guides are pretty good, we will be working constantly to improve and update these guides. Remember that if you notice a bug, you can help us by reporting it!

If you have trouble getting our addon to work, please check our "Troubleshooting Page" first. If you still need help, you can always stop by our "Friendly Chat Room"!

Ludovicus

Comments

Ludovicus_Maior's picture

Version 6.0.0E is out

OK Here are the changes:

  1.  One very embaraassing typo broke the TomTom/Carbonite Integration.
  2. All the Vashj'ir zones were missing.
  3. Debug message spam cleaned up.

Known problems:

  • The official TomTom has a few bugs which I will file later. (Most people will not notice)
  • The Astrolabe library TomTom uses has a few bugs which I will file later. (Caves and structures may have bad results)

Oh, and the Beta TomTom has been upgraded to a release version.

 

Emmaleah's picture

download??

Clicking on the Download button gives me an error 403 Forbidden (hummm. I thought that was supposed to be 404...)

Emmaleah == bravely leading the way since ... um a long time ago... Smiling

Ludovicus_Maior's picture

Re: download?? (now fixed)

Sorry about that.   I forgot to reset the permissions on the file so it was publicly accessible.

S3 is annoying sometimes.

No Tom Tom Arrows

I too am not getting the Tom Tom errows automaticaly on the guide. I am using the version that came out 10/20/14 6.0000-0.1.0 and the Wowpro that came outn 10/19/14 6.0(D). Tomtom is showing arrows for quests but not for the guide (looked in the opetions of both but don't see any where to set priorities).

 

Ludovicus_Maior's picture

Re: No Tom Tom Arrows

I have reproduced *a* missing TomTom arrow problem while starting the "Assault on the Dark Portal" guide.

I have verfied that the addon is not running the mapping code that sends the waypoints to TomTom.

Lets see if I can find out why this seems to work in Live, but not in Beta.

Ludovicus_Maior's picture

Re: No Tom Tom Arrows (Sweet Jesus)

Umm, I had:

i = WoWPro:NextStepNotSticky(WoWPro.ActiveStep)

where I should have had:

i = WoWPro.NextStepNotSticky(WoWPro.ActiveStep)

in WoWPro_Mapping.lua .   I suspect there may be other things wrong.

 

A simple zone name change from "Tanaan Jungle" to "TanaanJungleIntro" got the rest of the guide going.

 

Double Take

I sat here, puzzling, what was the difference between the two lines.  Took me half a minute to see it! 

Ludovicus_Maior's picture

BTW, Fluclo

The netrualized version of the Dark portal guide is quite nice, but it may expose another bug in the QO mechanism.

I noticed this in scenarios in pandaria, but now it is in the regular quests.  Quests with phased objectives.

For the quest [Altar Altercation], after you get rid of the 3rd ritual orb, it almost looks like "Head to Khadgar" is the first goal!

I'm going to have to look at this carefully.  If it is still the 4th goal, then we are not seeing the completiom of the 3rd goal.

What I recall from Beta was

What I recall from Beta was that it only displayed the current quest part on the HUD tracker, but when I went into the quest log itself, it displayed all steps. Can't check it at the moment, as Beta servers are down.

Ludovicus_Maior's picture

Re: What I recall from Beta was

Hmm, but if that was the case, I should have seen the completion on the 3rd ritual orb.But you are right, I am seeing the next objective with the right index, as if all were present.

Something is going wrong, in a wierd way.

 

Just tried that quest, and

Just tried that quest, and had the same problem you experienced.

The quest log lists each step, after completing the third blood ritual orb, the HUD displayed Blood Ritual Orb destroyed: 3/3, the quest guide updated the step to show (Complete), the HUD tracker moved onto Find Khadgar, but the guide stayed at 2/3 Blood Ritual Orb.

I have had past problems with the guide not advancing when there's a cut-scene, at this point there's a cut-scene, could that be where the problem lies?

When I /reload ui then it correctly moves to the next step. I also had to /reload ui a few times to get the right quest to show up in a few earlier quests of the zone - related problem?

Ludovicus_Maior's picture

Re: Just tried that quest, and

Hmm, I'll have to try it on another toon to see if it is the cutscene.

Great observation.

Ludovicus_Maior's picture

Re: Double Take

It was not until I printed the return value from the function and saw that it was "WoWPro" that I said "WTF!" and wondered why the function would return a string when an integer made sense.  Then I remebered that when you invoke a function with a :, the self argument get shoved in as the first and then I went, oops!

Time to cut the next take.

I've fixed a few WoWPro bugs, and now need to file some bugs with TomTom and Astrolabe.

Ludovicus_Maior's picture

Version 6.0.0D is out

Changes:

  1. Updates to the Hallow's End guides by Dez (thanks!)
  2. Updates to Goblin starter guides by Fluco
  3. Bug fixes to deal with C steps with multiple quest IDs not updating corrrectly (see #2)
  4.  Updated LibSharedMedia-3.0 to WoD version
  5. An update to my bootleg TomTom to make it quieter.

Known Problem:

  1. Need a semi-automatic way of dealing with quests whos objective texts have been changed in format by Blizzard.

If you have an old copy of the ACE libraries installed, update to:  Ace3-Release-r1122.zip

If you want my hacked TomTom, use:  Ludo_TomTom_2014_1019.zip.

I would still advise installing this, even though it is out of date: http://www.wowace.com/addons/blizzbugssuck/

 

 

Patch D/2014_1019 not TomTom friendly

Deleted my existing Ace3, Tomtom and WowPro folders, then went with the above three.

I'm getting chat lines with LFO: qid is # on every zone change, and everytime I finish attacking my TomTom waypoint is removed.

I tried old TomTom files with v6.0D and the waypoint arrow mis-behaved and the chat was spamming with zone infoI tried new TomTom files with v6.0C and waypoint worked fine (and there was no zone chat either)So it's the v6.0D files, and not the TomTom files that need looking at 

Ludovicus_Maior's picture

Re: Patch D/2014_1019 not TomTom friendly

Dang it!   The "LFO: quid" spam is from the change I made to support multiple QIDs in C steps.I thought I got rid of them all, but obviously missed one.  

I made no changes to the mapping code or zones code in D.

The only intended change in TomTom 1019, was getting rid of some chat spam  on zones changes (ZC).

I'll look for an unintended side effect in D then.  Thanks for trying the combinations.

 

 

Tomtom is in beta now, might

Tomtom is in beta now, might want to use that one?

beta_TomTom-v60000-0.0.1.zip

Emmaleah's picture

6.0.0D

My goodness you have been busy, I didnt even get to try 6.0.0C. I made 20 (small ) cakes this weekend for a bake sale.  (All but 5 sold...) Which means i dont want to look at cream cheese frosting for a few days and Im glad to be sitting in front of my cptr instead of my kitchen :).

OH, and then I allowed myself to be distracted by a book Green Rider by Kristen Britain.  It was pretty good, reminded me a bit of the Ranger Apprentice Series and I wondered if Halt and/or Will was the inspiration for the green riders, but they aren't the same at all. Also some forshadowing of improbably romance, but all in all, not a bad story.

Ill check out the update in the morning.

Emmaleah == bravely leading the way since ... um a long time ago... Smiling

Ludovicus_Maior's picture

Re: 6.0.0D cake sale

You go to sleep, I wake up an hour and a half later.

But now I want cake for breakfast!

Ludovicus_Maior's picture

Major Guide Bug Warning

It was reported to me in private email that some of the starter guides were not completing their C steps.

It turns out, when spinning up a Goblin to test things that:

  1. C steps with more than one QID were not displaying or handling the QO information
  2. Blizzard changed the format of the QO information!  For most quests it used to be "Get something: 1/1" and is now "1/1 Get something"

#1 I have a patch for that I am testing.

#2 will require either updating the guides to use the safer QO|# format or putting in the updated text.  I may be able to devise a patch to rewrite the QO text if it is in the first form and is not found.

Ludovicus_Maior's picture

6.0.0C is Out

Changes:

  1. Iron Horde Guide updates
  2. Missing guide entry in Profession_GuideList caused crash when viewing profession guides.
  3. Cut/paste error in Achievements_GuideList caused crash.
  4. Better map translation debugging for Emmaleah.
  5. Initialize WoWProDB.global.Deltas, crashed new users.

If you have an old copy of the ACE libraries installed, update to:  Ace3-Release-r1122.zip

If you want my hacked TomTom, use:  Ludo_TomTom_2014_1018.zip.

I would still advise installing this, even though it is out of date: http://www.wowace.com/addons/blizzbugssuck/

 

 

No TomTom Waypoint

No idea what changed, but it was working in the Beta/PTR, but on the Main Server, I find that the guide isn't putting a TomTom Waypoint.

TomTom (the alternative version) works if I type in /way 12.34 56.78, and when I put a tick in Guide Display > Show Coordinates, each step is showing the coordinates. However, it doesn't put the coordinates into the TomTom Waypoint. I can manually enter the coordinates, it just won't do it automatically.

There's no error messages, just the TomTomLFO: Start (...) for each zone change.

 

Ludovicus_Maior's picture

Re: No TomTom Waypoint

What version are you using of the addon and TomTom?

I'm about to cut new releases of both.

 

I too am not getting the Tom

I too am not getting the Tom Tom errows automaticaly on the guide. I am using the version that came out 10/20/14 6.0000-0.1.0 and the Wowpro that came outn 10/19/14 6.0(D). Tomtom is showing arrows for quests but not for the guide (looked in the opetions of both but don't see any where to set priorities).

 

No arrows

I too am not getting the Tom Tom errows automaticaly on the guide. I am using the version that came out 10/20/14 6.0000-0.1.0 and the Wowpro that came outn 10/19/14 6.0(D). Tomtom is showing arrows for quests but not for the guide (looked in the opetions of both but don't see any where to set priorities).

No arrows

I too am not getting the Tom Tom errows automaticaly on the guide. I am using the version that came out 10/20/14 6.0000-0.1.0 and the Wowpro that came outn 10/19/14 6.0(D). Tomtom is showing arrows for quests but not for the guide (looked in the opetions of both but don't see any where to set priorities).

Was using 6.0B. Now using 6.0C and things work

Was using 6.0B. Now downloaded 6.0C with the Ace and TomTom files at http://wow-pro.com/node/3609#comment-54110 and now the arrow appears to be working as expected. Thanks for your help getting this working for us all :)

Where can we find the new Tom

Where can we find the new Tom Tom am using an old one?

Ludovicus_Maior's picture

6.0.0B Trouble on Windows

OK.  I dusted off my old windows laptop and put a fresh install of WoD on it and got plently of errors.

I'm going to see if I can wipe my state on my Mac and reproduce most of the errors, since that latop has a tiny screen and my eyes are old :-).

Expect a status update (and maybe a real update) around noon, in six hours.

 

6.00B

Ok, it appears onscreen, however, attempts to enable and it disapears L/C or R/C have no effect and when visable, nothing appears in the menu, no guides, dailies etc

Ludovicus_Maior's picture

Re: 600B

Squibb, you gotta work with me here, since I know some people are succeeding.

Can you take screen shots showing what you see and post them somewhere where I can see?

 

600B

Am going into hospital today, will be away for some time, sorry, will catch up on return

Ludovicus_Maior's picture

Squibb & Hospital

Good luck on whatever they are doing to you!

Ludovicus_Maior's picture

6.0.0B Release notes

  1.  Wrong values in the Interface version in the .TOC files caused wierd loading failures for 6.0.0A
  2. Shifted Iron Horde guide to World Events instead of leveling
  3. Mean levels for guide automatically computed if not supplied, getting rid of tons of error messages.
  4. Guide updates not occuring during cinematics fixed
  5. Guide updates!

wow doesnt work

we downloaded  it and followed all ur steps and did it like we always do but its still not working

Ludovicus_Maior's picture

6.0.0A

  • Fixed spew in the console.
  • Got some missing guides to show up
  • Backed out a change that may have broken TomTom integration

The Iron Horde World event guides are still not showing up.,

That and TomTom are the next big problems to solve tomorrow.

Ludovicus_Maior's picture

Re: 6.0.0A not loading

I found the problem with 600A not loading.

It will be fixed within the hour!

 

6.0.0A doesn't load either "incompatible" in the list

Sorry - tried this one too and it didn't load or work at all either.

--
Ross Erickson
'Elmocorn' on Kilrogg

6.0 version broken

Same here.  Erased the old folders in the add-on directory... Downloaded/expanded the new version and copied them into the right directory... Loaded game, check all wow-pro boxes appropriately (even have load out of date add-ons checked)... go into game - Nada, zip, zilch.  No Wow-Pro frame - no way to turn it on.

Go into Addons from main menu:  ESC - AddOns ...  I see WoW-Pro (and 'child' addons - Achivements, Dailies, Leveling, Professions, World Events) all listed, but unchecked.  CAN'T CHECK THEM.  It also says they are "Insecure" in the 2nd column over.

Please make work!  :-)  I'm a leveller and need this addon badly.

--
Ross Erickson
'Elmocorn' on Kilrogg

Ludovicus_Maior's picture

Re; 6.0 version broken

If the WoWPro addons are showing up as "old" or "Insecure", it means you did not install them right and your old versions are still there somewhere.

 

What's happening for me is

What's happening for me is the wowpro is showing up normal under the addons tab in  game menu. However the Achievements, daillies, leveling, professions, worldevents start as disabled unchecked and when I check them are all in red. I've deleted my entire addon folder, logged into wow to create a new folder. Then added wowpro+v6.0.0A along withTomTom-v50400-1.0.0 and Naga_Anansi_WoWAddOn_v2.7.0_BETA. The (sub folders for WoW-Pro?) are the only folders not loading normally. I do have the Load out of date AddOns button checked. Now, when I look at the addons through the Interface tab (Game / Addons) the only addons showing up are Razer Anansi, Razer Naga and TomTom. WoWPro main addon does show there even though it shows in the addon tab as being loaded. (Normal gree color for Pro (in WoW-Pro) and a check marked the same as Razer Anansi and TomTom. To be sure I had the latest version of WoW-Pro I downloaded it again a few minutes ago. Same results. I do like the guide (although some waypoints are frustrating, but minor compared to how wonderful the addon works.) and would love to be able to continue using it with the prelaunch and launch of Draenor.

On a side note, I got to say, this captcha thing at the end, though I can see why it's needed, with the "snow" in the background, I can't make out a lot of the letters. I've gone though three tries now with mistakes each time. Some of the letters are nice and easy to read, can we make ALL of the letters easy to read? Human eye read not computer read.

God D this capcha thing! 15 tries now!

Seriously??? 25 tries and I can't get the f'ing captcha thing right??? I'm NOT a computer. I'm NOT a spammer. I've posted here maybe, at most, 5 times!

Edit: Ok, I discovered what "I" was doing wrong. I had wiped my addons to make sure everything was new for WoD. I had forgotten to include ACE3 into my addons. Apparently all my other addons don't need it. Anyway, got it loaded and wow-pro is loading both in interface and addons under the game menu. Seems to be working like a champ now. Here I go braving the captcha thing again. Not sure about you guys, but I feel sorry for me. :'( I promise not to say a word even if it takes me 30 tries to save it.

6.0.0a not working

I'm having the same problem. I deleted all my existing wow pro folders, reinstalled them all. They all show as up to date and selected in the list both on character select and in game under esc/addons. But I'm getting nothing, there's no button on my mini map, nothing under interface/addons. Mine aren't showing as old or insecure, everything shows like its ready and loaded, but zip.

Wow-Pro addon not showing in game

I installed the addon in the same manner I have been for years but this time it didn't show up in game. I have the "Load out of date addons" checked, just in case.

Any thoughts?

Bobkat's fix worked, but broke my TomTom

6.0.0A caused Wow-Pro to disappear again

Deleted old addon, copied new addon to the addons folder.

Now it isn't showing up again. Tried the files from github.com with the same results. No wow-pro in game.

 

and the captcha really sucks. some of the letters are so small as to be unreadable. I have to submit my post numerous times to get it to take. Perhaps a refresh button for the captcha image would help?

Doesn't work for me either...

Same here.  Erased the old folders in the add-on directory... Downloaded/expanded the new version and copied them into the right directory... Loaded game, check all wow-pro boxes appropriately (even have load out of date add-ons checked)... go into game - Nada, zip, zilch.  No Wow-Pro frame - no way to turn it on.

Go into Addons from main menu:  ESC - AddOns ...  I see WoW-Pro (and 'child' addons - Achivements, Dailies, Leveling, Professions, World Events) all listed, but unchecked.  CAN'T CHECK THEM.  It also says they are "Insecure" in the 2nd column over.

Please make work!  :-)  I'm a leveller and need this addon badly.

--
Ross Erickson
'Elmocorn' on Kilrogg

Ludovicus_Maior's picture

Boogers (Oct 14, 18:00)

Known bugs in 6.0.0:

  1. Spires of Arak guide misnamed
  2. Alliance Shadowmoon guide missing
  3. Horde Nagrand guide missing
  4. Horde and Alliance Iron Horde guides missing
  5. Lots of debugging messages got left in and meed to be turned off.

There will be another cut today.

Kraylessa's picture

TomTom?

I know this isn't your mod, but it's critical to the function of WoW-Pro and doesn't seem to be working for me in 6.0.2. Any suggestions?

Ludovicus_Maior's picture

Re: TomTom?

Yeah, neither Carbonite nor TomTom have posted updates as of right now..

I'll give them till high noon Thursday (Boston Time) to post updates.

If there are no fixes for WoD, then I wiil post my private version of TomTom that mostly works.

Steps don't progress after a

Steps don't progress after a cinematic (they show a tick, but the next step only shows up if you leave the area or untick and retick)