LATEST NEWS

General Bug Reporting

img
Dec
01

Known Bugs:

Before submitting a bug, please check this list to make sure you aren’t repeating a submission!

Submit Your Bug:

When submitting your addon bug, you MUST include the following:

  • The version number of your WoW-Pro installation
  • Any error text that WoW provided when your bug happened
  • Information about the guide you were using when the bug happened, including:
    • Faction (Alliance/Horde)
    • Zone
    • What step you were on
  • As many details as possible about what you were doing when the bug occurred.

Including this information will help us troubleshoot and possibly get you a temporary solution to the bug, and get it fixed as quickly as possible!

  • img
    Chronicles
    Dec 11, 2016 @ 22:40 pm

    Settings not saved between sessionsSince version 7.1.0C I have issues with the settings of the addon not beeing saved between sessions. Quest difficulty, view settings, which guide was last used etc. Anyone seen any similar issues? Chron.

  • img
    Dec 8, 2016 @ 23:02 pm

    Re: Errors occurring with newest versionThanks for the report.  The fix is in tonight’s release.

  • img
    Dec 8, 2016 @ 20:07 pm

    Main addon missing?In you addons directory do you have a wowpro directory? if it is anywhere other than that, it won’t work.See [url=https://wow-pro.com/wiki/addon_troubleshooting_guide]Troubleshooting Guide [/url]

  • img
    Ookami.kun
    Dec 4, 2016 @ 2:21 am

    Errors occurring with newest version.For the last version or two, I’ve been getting the following error whenever I zone into an instanceVersion 7.1.0D Date: 2016-12-03 19:55:09ID: 2Error occured in: GlobalCount: 4Message: ..AddOnsWoWProWoWPro_Mapping.lua line 305:   attempt to perform arithmetic on local ‘x’ (a nil value)Debug:   (tail call): ?   WoWProWoWPro_Mapping.lua:305: MapPointDelta()   WoWProWoWPro_Broker.lua:1302: CompleteStep()   WoWProWoWPro_Broker.lua:798: NextStep()   WoWProWoWPro_Broker.lua:385:      WoWProWoWPro_Broker.lua:349   (tail call): ?   [C]: ?   [string “safecall Dispatcher[1]”]:9:      [string “safecall Dispatcher[1]”]:5   (tail call): ?   …ceAddOnsArchyLibsAceBucket-3.0AceBucket-3.0.lua:118: func()   …sAckisRecipeListlibsAceTimer-3.0AceTimer-3.0.lua:55:      …sAckisRecipeListlibsAceTimer-3.0AceTimer-3.0.lua:48Locals:NoneAddOns: I will also get the following error during combat. This one actually causes my game to locjup for a few seconds which can, as you imagine, cause some issues. :)Date: 2016-12-03 20:07:20ID: 3Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro.lua line 131:   script ran too longDebug:   [C]: debuglocals()   WoWProWoWPro.lua:131: LogError()   WoWProWoWPro.lua:144:      WoWProWoWPro.lua:139   [C]: ?   WoWProWoWPro.lua:46: Add2Log()   WoWProWoWPro.lua:64: print()   WoWProWoWPro_Broker.lua:1501: PopulateQuestLog()   WoWProWoWPro_Events.lua:738:      WoWProWoWPro_Events.lua:440Locals: AddOns: Other than those issues, addon works great as usual. Thanks for all the hard work to the team. 

  • img
    iron
    Dec 2, 2016 @ 0:29 am

    downloading wowpro latest version 12/2/2016when i dl wowproi get all the addons exept the main wowpro addon.the rest say missing the dependancy addon (wowpro)

  • img
    Nov 29, 2016 @ 13:57 pm

    Re: Addon leaves Trade Skill Filters setPlease try the developers versionof the addon at: https://github.com/Ludovicus/WoW-Pro-Guides/archive/master.zip The recipie detection code has been revamped. Skillet and Ackis have been taken into consideration.

  • img
    b-morgan
    Nov 27, 2016 @ 21:40 pm

    Addon leaves Trade Skill Filters setWith WoW-Pro addon installed, if I open a tradeskill, there is a filter set limiting the recipes that appear. This is annoying and can cause other Tradeskill addons (like Skillet) to fail completely.

  • img
    tubera
    Nov 26, 2016 @ 16:33 pm

    Which versionWhich version did you download?Ludo updatedthis week because 7.1.0T had a wrong tag value in the .toc file, causing this issue.

  • img
    Nov 26, 2016 @ 4:58 am

    RE: Incompatible AddonI have omen and am experiencing no problems. I would second Blanckaert’s advice.

  • img
    Nov 26, 2016 @ 2:25 am

    RE: Addon incompatibleHmm… I have Omen, and it isn’t tossing incompt error for Me, yes, you might want to try redownloading Omen, Wowpro, and tomtom..that would be a start…  or disable omen, and restart the game.. and see what happens

  • img
    odin1810
    Nov 22, 2016 @ 21:50 pm

    Addon incompatible?i downloaded this addon a couple of weeks ago and have been using it a whole bunch with no problem on all of my characters. the other day i decided to download a threat table addon through curse, and now when i load into the game it shows that the addon isnt loading in. it simply says it is “incompatible” and that i need tomtom or that other addon to make it work…i have tomtom downloaded and enabled. the only thing that changed since my previous times using it was downloading the threat table addon (omen). any idea on what i should do? should i just delete the addon and try downloading it again?

  • img
    Barleduq
    Nov 16, 2016 @ 12:31 pm

    out of orderYeah, I’m halfway through Stormheim on one toon, and I had run out of order hall resources. I went back into Stormheim with the addon enabled, and lo, it pointed me at a treasure. So I was running after treasures. (which was good, I got over 1k resources, tho now I’m out again. That’s the problem with the mobile app for the order hall missions.)I’ll try to put things in the right place, really I will! 😀  

  • img
    Nov 15, 2016 @ 9:32 am

    Trapped treasure. That treasure is actually in the guide.Its right after Kill Tiptog the lost and just before doing quests for the tauren couple that have the misfortune to meet up with some detestable goblins. (the sixtrigger brothers).K Kill Tiptog the Lost|QID|38774|M|46.29,50.01|T|Tiptog the
    Lost|QO|1|ITEM|129163|N|Silver – Kill and loot for a bit of treasure and
    resources.|RANK|2|
    $ Glimmering Treasure
    Chest|QID|38763|M|49.70,49.20;49.69,47.28|CS|N|Dodge the energy beams,
    open the chest, be ready to fight. Loot for a bit of treasure and
    resources.|RANK|2|
    A Eating Into Our Business|QID|39789|M|51.46,56.95|N|From Ootasa Galehoof.|RANK|2|

  • img
    Nov 15, 2016 @ 9:16 am

    where to post.The best place to put things related to a specific guide is on the page for that guide.  You can find them from https://wow-pro.com/node/3196which is from the menu Addon > Community Page > View and Update Guide Sourcecode and then pick the specific guide.Technically it should be report bug with specific guide, (instead of view and update guide sourcecode) but I see that the Legion guides havent been linked to that page 🙁 To your specific situation.  That line (hop down to get this treasure) should be while you are on the walls of hrydshal killing drakes for scales and disabling the harpoon launchers for Horde.  I see it was moved for Alliance and the description wasnt changed, but it still while you are at Hrydshal.  I am guessing you were coming back looking for missed treasures after you had already done the quests?

  • img
    Barleduq
    Nov 15, 2016 @ 6:47 am

    So I was following an arrow to treasure…… which is actually the primary reason I dl’ed this addon….and found one, inside a cave by where we were finding Yotnar’s missing pieces before putting him back together. I found hte chest up the grapple path to the top of a spire. I then got ‘while you are o the wall, hop down and get this chest…’ except the next chest it was pointing to was 1024 yards away, and there was no place to ‘hop down’ to in that direction. (Fortunately, I took the talent that eliminates falling damage. This is why. 😀 )  There also isn’t any waypoint on my world map for this; at least, I can’t find it. I don’t know where to put questions like this, when something doesn’t make sense, or it looks like I’ve missed something.  

  • img
    Barleduq
    Nov 15, 2016 @ 6:28 am

    NopeI don’t use any profession addon. I used to use TradeSkillDW but it broke and hasn’t been fixed as far as I can tell.

  • img
    Barleduq
    Nov 15, 2016 @ 6:26 am

    So where would I post something that seemed to be missing from..…. from a guide? I don’t know where to put this, but it isn’t a bug. I found a treasure chest that doesn’t seem to be in the guide – at least, I didn’t see it on the map.  There’s a Glimmering Treasure Chest inside a cave called Terrace of the Watchers in Stormheim.  There are a number of statues in there, holding glimmering balls with beams of light angling to the ground, and moving around. They zotted me when I got too close. The chest is at 49.70, 47.31 (as I was standing on top of it). When I opened it, I didn’t seem to get any loot, but one of the statues animated and started smacking me. 😀 So maybe this isn’t a chest missing in the guide, but I didn’t seem to find anything in the guide about it. (I’m probably not doing it right.) The entrance to the cave is at 49.75, 49.43 in the subzone Amberfall Mesa.I looked at the forums, but the most recent post (as shown in the top level listing) was like 2 years ago, so that seemed counterproductive. ETA: I went back in after escaping from dying (love rogue’s vanish) and ended up killing 2 statues. They were lootable, and mineable; I clicked the treasure chest again and didn’t get attacked, and got Tattered Explorer hat (grey, id: 121406), Calcified Dragon Egg x3 (grey, id: 138251), Damaged Berserker’s Plate Helm (grey, id: 121405), Mandate of the Watchers (blue, id: 132897, gives 45 AP), and ORder Resources x207. 

  • img
    tubera
    Nov 15, 2016 @ 6:04 am

    I had the same thingDo you use Skillet?If so try deleting the skillet savedvariables file. That worked for me

  • img
    Barleduq
    Nov 15, 2016 @ 2:31 am

    Bug with *i believe* wowpro, on opening professionsL87 nelf rogue in Northrend Dalaran. Alchemy at 600. Logging in to do the daily xmute to try for new recipes. I have the prof on my action bar. Press key to open, it opens up with both Have Mats and Have Skillup checked – which is not how I leave it, ever, because Altoholic gets cranky if you leave things with filters on. Message in chat:  WoWPro: Opened Alchemy Window (next line) WoWPro: Located 0 recipeIDs. Indeed, the list of recipes on the left side is blank, as I have nothing that gives skillup at the moment. I uncheck the filters and close the window.  Open it again, and again the two filters are checked, and the same messages show up in chat.  I looked for a setting about this, but did not find one.

  • img
    Barleduq
    Nov 15, 2016 @ 2:25 am

    I’m spoiled… by wowinterface.com, that has an opt-in to be notified when an addon is updated, and a different one to be notified when a comment is made on an addon’s page. Curse only sort of does the comment notification, and doesn’t do the update notificatino at all. I presume they rely on people using the automagic updater. I use Linux, and I have enough angst and agida making WoW work under WINE emulation, I really don’t want to deal with Another Program. Thanks, I guess I’ll just try to remember to hit here. 

  • img
    Nov 14, 2016 @ 3:40 am

    RE:NotificationsTo my knowledge, there is no way to get notifications from this webside, what I do *besides looking at the recent comments box* is also look at “recent activity” off of the menu (Community > Recent Activity).  That catches the items that have fallen off of the recent comments box.  To get notice of updates to the addon… Ludo does a guide updates to the beta version twice a day 3am/3pm EST.  I don’t know that he plans to keep this schedule up for that much longer as the pace of updates is much lower than it was at the beginning of the expansion.  You can find the latest beta version at github.  https://github.com/Ludovicus/WoW-Pro-Guides/tree/master. Unless its a serious bug, the official release gets updated every 2 weeks I think. The Trial version on Curse gets updated each game update (7.0, 7.1, etc) and has a limited selection of guides.

  • img
    Barleduq
    Nov 13, 2016 @ 22:46 pm

    No need to apologizeYes, it’s frustrating but honestly? As long as you see my reports as useful, and let me know that they’re at least acknowledged, I’m ok with it. I’m married to a programmer, and I tried coding in college and found that I was the type of coder who would shut out the entire world and miss people talking right next to me. Between that, and being unable to keep up with the math in the theory courses, I gave up. That doesn’t mean I’ve forgotten the “joys” of making a virtual object do my bidding! 😀 btw, is there any setting where I could get notifications of replies to my comments? Like this one? In my email?  I did tick the box for getting email notifications of private messages, but I don’t necessarily check every website daily for things, and that could be a reminder to do so, and/or that I don’t need to bother. Also, some way to get notified that the addon’s been updated would be lovely. I realize this is a bug thread, but I haven’t found the feature/suggestion thread yet. 😀  

  • img
    Nov 13, 2016 @ 12:45 pm

    DK, sub lvl 100 It is trying to load a guide it shoudlnt try to load…The order hall guides all have 98 as thier lower limit. *which you are seeing in the guide panel,*  This one’s for Ludo.  I know the code looks first for class/race guides so it can load the correct guide for a new character but it apparently isnt respecting the level limit.You are doing a great service. We need to have people checking and reporting in a variety of situations to find this kind of stuff.(As to your comment about being good at finding bugs… I swear I find every spot on the map that you can get stuck in with no way out but to hearth… so irritating, so I apologize you are having that sort of experience with this.)

  • img
    Barleduq
    Nov 13, 2016 @ 9:49 am

    New one!I logged into my lowish level DK (mostly an AH alt), L64 DK in Darnassus, wearing various pieces of holiday clothing. I got the following messages in chat, but NO errors as caught by Swatter:WoWPro: Initializing Guild EmmLegionDKWoWPro: 181 Empty Value for tag |M| in [P Stormwind|QID|42818|M||Z|Dalaran@Dalaran70|N|Take the Stormwind Portal.|FACTION|ALLIANCE|ACTIVE|42818|].WoWPro: Missing coordinate, 1/1 in guide EmmLegionDK, Line [P Stormwind]WoWpro: 218: Empty value for tag |M| in [P Stormwind|QID|43686|M||Z|Dalaran@Dalaran70|N|Take the Stormwind Portal.|FACTION|ALLIANCE|ACTIVE|43686|].WoWPro: Missing coordinate, 1/1 in guide EmmLegionDK, line [P Stormwind]. I had to copy this by hand, as I can’t cut/paste from chat (and addon spew isn’t caught by my addon that catches chat for me to later be able to see and/or grab) so there might be typoes that I’m missing as I look at it.  I have a small rectangular box that’s transparent with a slightly shaded header. The header reads Death Knight Order Hall (0/313) and the rest of it has what looks like a checkbox next to an icon of a shaded white plus sign on a blue background, Level 98 and under in smaller yellow type You need to be level 98 to start this guide. 

  • img
    Barleduq
    Nov 13, 2016 @ 8:01 am

    Not sure if this is the same bug.I had wowpro disabled. I clicked on the minimap button to enable it. the box showed up, with the title of WoW-Pro Guides, but nothing in the unshaded area. I left clicked on it, nothing happened. I right clicked on it, and got this error.  I’m removing the list of addons. The only possible thing relevant to ‘combat raid frames’ is that I had created a custom group because I had the leather trader in my garrison; there were some random hoppers in it, in combat (I’m guessing since the HP was moving on one) and I left the group. This was about 2-3 minutes before I clicked to enable wow-pro.  I will also be reporting this to metamap. No clue why clicking on a wow-pro created frame caused a problem attributed to metamap. Date: 2016-11-13 01:37:23ID: 1Error occured in: AddOn: MetaMapCount: 1Message: Note: AddOn MetaMap attempted to call a protected function (CompactRaidFrame3:SetAttribute()) during combat lockdown.Debug:   [C]: SetAttribute()   ..FrameXMLCompactUnitFrame.lua:156: CompactUnitFrame_SetUnit()   …actRaidFramesBlizzard_CompactRaidFrameContainer.lua:318: CompactRaidFrameContainer_AddUnitFrame()   …actRaidFramesBlizzard_CompactRaidFrameContainer.lua:254: CompactRaidFrameContainer_AddPlayers()   …actRaidFramesBlizzard_CompactRaidFrameContainer.lua:176: CompactRaidFrameContainer_LayoutFrames()   …actRaidFramesBlizzard_CompactRaidFrameContainer.lua:130: CompactRaidFrameContainer_TryUpdate()   …actRaidFramesBlizzard_CompactRaidFrameContainer.lua:57: CompactRaidFrameContainer_OnEvent()   [string “*:OnEvent”]:1:      [string “*:OnEvent”]:1Locals:NoneAddOns:  BlizRuntimeLib_enUS v7.1.0.70100 <none>  (ck=133c) 

  • img
    Barleduq
    Nov 13, 2016 @ 5:33 am

    I’m talented that wayI often end up finding things that are broken, I’ve been told this before by other addon authors. 😀  That particular character… I’m not sure when I’m going to take it into Legion; it’s mostly a crafter character, and I pulled it into WoD in my second-tier of upleveling due to the easy crafting stuff, so I could make gold for tokens. The crafting in Legion is byzantine, and I’ve ben too busy trying to figure out how to work leveling on 3 diff toons to figure out actually *making* anything (as opposed to gathering). I mean, My JC (hunter) is one of the first I pulled up, and “go find someone who might know about this ring thing” didn’t give me any clue as to where to go, and I’d already chosen a zone that apparently wasn’t it… I was all the way through Valshara and most of the way through Highmountain when I found Azsuna on another character and went Oh hey, that’s a similar name….. *facepalm*I’m a bit disappointed, actually, that trying to select a guide seems to be broken; the first toon I tried to use this on was my JC, and in choosing JC I got an error about selecting guides, and couldn’t figure out how to make the JC guide work, and then couldn’t switch to anything else. I’m honestly finding trying to use this more frustrating than anything else. It seems that what I wanted it for is what’s unavailable. Thanks for the replies!-Barleduq 

  • img
    Nov 13, 2016 @ 3:21 am

    errorIm not the person to help with errors, but I thought I would comment on: I’ll note, I had disabled the addon in the Interface list, and had
    expected that to disable it entirely. I did NOT expect it to show up on
    subsequent characters. :/ The disable that is in the wowpro addon menu is only for that character,  It doesnt unload it from memory (like the blizzard UI option would) but instead makes it not functional until re-enabled for that char.When you get the option do you want to load…there are three options Yes/No/and Dont Ask.  For Bringing in the Base (or anyother quest you have in your log that you don’t particularly plan to do for awhile and would prefer not to be bothered with the popup constantly…Choose Don’t ask.  That disables the popup from occuring until you reset the guide from the menu.

  • img
    Nov 13, 2016 @ 3:14 am

    new to addonAs to the error… There is a module that is supposed to easily enable guide switching but unfortunately it is non functional right now.  I don’t recall ever getting an error related to it except when trying to actually use it, but I think that is what that error refers too. (Message: ..AddOnsWoWProWoWPro_Broker.lua line 731:   attempt to index field ‘Selector’ (a nil value)As to profiles… You are hitting all the broken places today *terribly sorry for that*  but profiles are not properly saving so if you don’t like the dedault profile (I dont) You have to reset those options each time you log in.  That being said, the default profile isnt that bad.  The only really bad part of this bug is it won’t usually remember what guide you were in the middle of, and so you have to go to guide list and select you guide on almost every log in. Now for what does work :)When you first log in and see the pop up (probably asking you if you want to switch to the guide for “in the blink of an eye”?) say yes, and the Warrior Order Hall guide should load.  (assuming you are on a warrior).  If the guide you want doesn’t load, you can go to the menu [ESC>INTERFACE>ADDON tab>WOW PRO, click the “+” to expand the menu, and choose select guide and choose from the list which guide you want (the zone you are going to quest in)].  Im guessing you arent new to legion, just this character is, so you know the basic way order halls work and chooseing next zone at the command table and such.This expansion provided a lot more quest variety between classes with order halls and the like, most of the order hall guides only show the very first steps.  Paladin and DK are complete, Mage, Monk, Hunter and Priest are significantly beyond the beginning and as far as I am aware, all the rest of the class guides only cover thru getting all of your artifact weapons. We are working on getting them all done, but it was a much bigger undertaking than previous expansion guides have been.The zone guides are all completed and while there may be some minor tweaks that could improve them, I feel they are pretty good.Welcome to WowPro and anything I can do to assist using the guides, let me know.

  • img
    Barleduq
    Nov 12, 2016 @ 7:36 am

    Next toonI logged in. It asked me if I wanted to switch to the guide for Bringing the Bass. I clicked no. Then I got this. Now, it doesn’t say what addon threw the error, but the error popped when I clicked No on the pop up, so I’m reporting it. 7.1.0B. Alliance Rogue, standing in the Rogue Order Hall. I’ll note, I had disabled the addon in the Interface list, and had expected that to disable it entirely. I did NOT expect it to show up on subsequent characters. :/ I’m removing my list of addons, you can see them in my other message.Date: 2016-11-12 01:31:46ID: 1Error occured in: GlobalCount: 1Message: constant table overflowDebug:   [C]: ?Locals: AddOns:[addon list removed for brevity]  BlizRuntimeLib_enUS v7.1.0.70100 <none>  (ck=107d) 

  • img
    Barleduq
    Nov 12, 2016 @ 7:28 am

    Rank Newb Just starting to use this addonVerion 7.1.0B (just downloaded today). This is an Alliance Warrior. So I installed it and logged in. This alt is a L100 Warrior, maxed tailoring/blacksmithing. It’s mostly a crafting toon, so I actually haven’t done much of the Draenor questing; just enough to bring me up to 100, and then into Tanaan to get oil cause the ship missions drop elemental mats. I have accepted the quest to go to Recruiter Lee in Stormwind, but haven’t otherwise done anything with Legion. When I first logged in, I got a pop up asking if I wanted some guide. I actually don’t remember what, because there was a blingtron 5k visible on my minimap, and I was trying to get to it cause it gives me mats. I failed to find it in time, and somewhere in there the popup went away without my ever clicking on it. A box labeled Warrior Order Hall is visible in the same place as my modified objectives tracker. I don’t know what to do with it, because I don’t know what the quest that’s listed on it means. I opened the Interface->Addons and looked at the settings. I left the checkmark to enable the addon, and I checked Grail Integration. I then went to profiles and shifted it from Default ot the one named for this CharacterName-Realm, and this error popped up in Swatter:Date: 2016-11-12 01:19:34ID: 1Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro_Broker.lua line 731:   attempt to index field ‘Selector’ (a nil value)Debug:   (tail call): ?   WoWProWoWPro_Broker.lua:731: NextStep()   WoWProWoWPro_Broker.lua:320:      WoWProWoWPro_Broker.lua:284   (tail call): ?   [C]: ?   [string “safecall Dispatcher[1]”]:9:      [string “safecall Dispatcher[1]”]:5   (tail call): ?   …ceAddOnsArchyLibsAceBucket-3.0AceBucket-3.0.lua:118: func()   …AddOnsDataStorelibsAceTimer-3.0AceTimer-3.0.lua:55:      …AddOnsDataStorelibsAceTimer-3.0AceTimer-3.0.lua:48Locals:NoneAddOns:  Swatter, v7.0.3 (<%codename%>)  WowheadLooter, v60014  ACP, v3.4.30   AdorableHatchlingNests, v2.06  AdvancedXPBar, v7.0.0.160625  Altoholic, vr174  Analyst, v1.4.0  Archy, v7.1.0.1  AucAdvanced, v7.2.5688 (TasmanianThylacine)  AucFilterBasic, v7.2.5688 (TasmanianThylacine)  AucFilterOutlier, v7.2.5688.5459(7.2/embedded)  AucMatchUndercut, v7.2.5688.5585(7.2/embedded)  AucScanData, v7.2.5688 (TasmanianThylacine)  AucStatHistogram, v7.2.5688 (TasmanianThylacine)  AucStatiLevel, v7.2.5688 (TasmanianThylacine)  AucStatPurchased, v7.2.5688 (TasmanianThylacine)  AucStatSales, v7.2.5688.5598(7.2/embedded)  AucStatSimple, v7.2.5688 (TasmanianThylacine)  AucStatStdDev, v7.2.5688 (TasmanianThylacine)  AucStatWOWEcon, v7.2.5688.5613(7.2/embedded)  AucUtilAHWindowControl, v7.2.5688.5575(7.2/embedded)  AucUtilAppraiser, v7.2.5688.5666(7.2/embedded)  AucUtilAskPrice, v7.2.5688.5599(7.2/embedded)  AucUtilAutoMagic, v7.2.5688.5686(7.2/embedded)  AucUtilCompactUI, v7.2.5688.5629(7.2/embedded)  AucUtilEasyBuyout, v7.2.5688.5576(7.2/embedded)  AucUtilFixAH, v7.2.5688 (TasmanianThylacine)  AucUtilItemSuggest, v7.2.5688.5651(7.2/embedded)  AucUtilPriceLevel, v7.2.5688.5633(7.2/embedded)  AucUtilScanButton, v7.2.5688.5631(7.2/embedded)  AucUtilScanFinish, v7.2.5688.5588(7.2/embedded)  AucUtilScanProgress, v7.2.5688.4979(7.2/embedded)  AucUtilScanStart, v7.2.5688.5347(7.2/embedded)  AucUtilSearchUI, v7.2.5688.5672(7.2/embedded)  AucUtilSimpleAuction, v7.2.5688.5654(7.2/embedded)  AucUtilVendMarkup, v7.2.5688.4828(7.2/embedded)  AutoRepair, v  Babylonian, v5.1.DEV.332(/embedded)  BadBoy, vv7.1.16  BadBoyCCleaner, vv7.1.1  BadBoyHistory, v1.31  BadBoyIgnore, vv7.1.0  BattlePetCount, v1.8.10  BattlePetTabs, v7.0.0.160625  BeanCounter, v7.2.5688 (TasmanianThylacine)  BelowAverageItems, v1.23  BindsWhen, v7.1.0.0  BOPCraftConfirm, v1.2.3  CanIMogIt, v7.0.3.23  ChatLoot, v1.6.1  ClassicQuestLog, v1.2.7  Comix, v6.2.3.0  Compass, v1.0.6  Configator, v5.1.DEV.406(/embedded)  CritterEmote, v1.8  DarkmoonProfessional, v7.0.3.1  DataStore, vr61  DataStoreAchievements, vr44  DataStoreAgenda, vr24  DataStoreAuctions, vr46  DataStoreCharacters, vr37  DataStoreContainers, vr54  DataStoreCrafts, vr75  DataStoreCurrencies, vr33  DataStoreGarrisons, vr18  DataStoreInventory, vr47  DataStoreMails, vr47  DataStorePets, vr40  DataStoreQuests, vr39  DataStoreReputations, vr38  DataStoreSpells, vr28  DataStoreStats, vr27  DataStoreTalents, vr56  DebugLib, v5.1.DEV.337(/embedded)  DragEmAll, v1.0.6  Dresser, v7.0.0.160625  Elephant, v3.5.1  Engravings, v  ExaltedWithTheFloor, v2.  ExecutiveAssistant, v1.0.2  Exonumist, v7.1.0.0  FactionAddict, v1.39  FarmIt2, v  FishingBuddy, v1.7.11  FlightMapEnhanced, v2.1.4  GnomishVendorShrinker, v  GoFish, v7.1.0.1  Grail, v083  GrailAchievements, v011  GrailQuestsenUS, v22810  GrailReputations, v007  GrailWhen, v001  GuildRosterButtons, v5.0  HearKitty, v1.7.4a  HearKittySoundPacks, vVolume 2f  HereBeDragons10, v1.14-release  IgnoreMore, v1.1.1-40300  InFlightLoad, v7.1.001  KeepingTabs, v1.5  KillTrack, vv2.11.2  LagBar, v3.6  LibExtraTip, v5.12.DEV.416(/embedded)  LightHeaded, vwowi:revision  Linkerize, v009  Livestock, v2.5.1  LootMsgShortener, v0.71  MasterPlanA, vA  MetaMap, v7.1.0.1  MetaMapBWP, v7.1.0.0  MetaMapFWM, v7.1.0.0  MetaMapNBK, v7.1.0.0  MetaMapQST, v7.1.0.0  MetaMapTRK, v7.1.0.0  MetaMapWKB, v7.1.0.0  MicroMenu, v1.2.3  MiniLoot, v7.1.0.161026  MobKillCount, v7.1.0  MountFarmHelper, v7.1.0  NameplateColors, vv1.2.2  Overachiever, v0.98  OverachieverTrade, v0.98  Pawn, v2.1.8  PetFarmHelper, v7.1.0  PetLeash, v3.1.1  PetTracker, v7.1.0  PetTrackerBreeds, v  PetTrackerConfig, v  PetTrackerJournal, v  PetTrackerSwitcher, v  PetTrackerUpgrades, v  Postal, vv3.5.8  QuickQuestItem, v3.0  RangeDisplay, vv4.5.0  RaresTip, vr10  SanityCheck, vv1.69  SayRandomQuote, v7.0  SemlarPlates, v7.1.0.1  SilverDragon, vv3.2.9  SimpleDing, vv1.0  SimpleGold, v5.5.0  Skada, v1.5-14  Skadacfi, v0.4c  SkadaScroll, v1.5.3  SlideBar, v7.0.3 (<%codename%>)  SpeedyGonzales, v1.7.6  StoreBeGone, v1.2  Stubby, v7.2.5688 (TasmanianThylacine)  TabardAddict, v2.34  TargetNameplateIndicator, v1.11  TheUndermineJournal, v4.7.20161108  TinyPad, v2.1.3  TipHelper, v5.12.DEV.405(/embedded)  TipTop, v2.16.2  TokenSplainer, vr04  TomTom, vv70100-1.1.0-49459b0  WardrobeSort, vv0.2.2  WhoFramedWatcherWabbit, v2.2.1  Wholly, v060  WowheadBagScanner, v1.11  WoWPro, v7.1.0B  WoWProAchievements, v7.1.0B  WoWProDailies, v7.1.0B  WoWProLeveling, v7.1.0B  WowProProfession, v7.1.0B  WoWProWorldEvents, v7.1.0B  WoWTokenWatch, v1.0.3  ZoneAchievementTracker, v7.1.0.0  BlizRuntimeLib_enUS v7.1.0.70100 <none>  (ck=12d9)I’m not sure what to do from here, so I’m just going to disable it for now, until I can set this up to have different profiles.  

  • img
    HuntsTheWind
    Oct 30, 2016 @ 19:01 pm

    7.1.0 conflict with Skillet add onThis may be related to the known bug with not reading trade skill spells. When I have both WowPro and Skillet enabled, and try to open the trade skill window (in this case Cooking), WowPro prints the following in the chat window:“WowPro: Opened Cooking windowWowPro: Located 0 recipeIDs” The trade skill window then fails to open. Skillet throws the following error:2x SkilletUIMainFrame.lua:1391: bad argument #1 to ‘pairs’ (table expected, got nil)[C]: in function `pairs’SkilletUIMainFrame.lua:1391: in function `HideDetailWindow’SkilletUIMainFrame.lua:1405: in function `UpdateDetailsWindow’SkilletUIMainFrame.lua:767: in function <SkilletUIMainFrame.lua:740>(tail call): ?SkilletSkillet-3.13.lua:1279: in function `?’…OnsAce3CallbackHandler-1.0CallbackHandler-1.0-6.lua:145: in function <…OnsAce3CallbackHandler-1.0CallbackHandler-1.0.lua:145>[string “safecall Dispatcher[1]”]:4: in function <[string “safecall Dispatcher[1]”]:4>[C]: ?[string “safecall Dispatcher[1]”]:13: in function `?’…OnsAce3CallbackHandler-1.0CallbackHandler-1.0-6.lua:90: in function `Fire’Ace3AceEvent-3.0AceEvent-3.0-3.lua:120: in function <Ace3AceEvent-3.0AceEvent-3.0.lua:119>Locals:nil I find both the WowPro addon and Skillet very useful – I hope you can deconflict!

  • img
    Oct 25, 2016 @ 2:05 am

    Debug modeoh, sorry. I thought that was the conclusion we came to when I sent you what I thought might be a clue and turned out not to be helpful, but the fact it didnt happen to me in debug mode, but did when I forgot to turn it back on after zapping my WTF file was a clue.

  • img
    Oct 25, 2016 @ 0:31 am

    Re: The menu problem (scream!)Aaaaaaaaah!   I’m sorry if I forgot someone mentioned this was fixed in debug mode and was a non-debug mode problem.This clue may make it easier for me to fix. 

  • img
    Oct 24, 2016 @ 22:06 pm

    The menu problemThere is an addon called Blizz bugs suck.  If you install it, it will let you right click on the title bar of the guide pane and have the menu come up as it should.  The addon also fixes many other bugs that blizzard has made over the years and it’s authors maintain it so it only fixes current bugs.  (Alas it doesnt fix maxcameradistance because Blizz’s change is an intentional change, not a bug)As to the resetting, apparently it doesnt happen if you run with wowpro in debug mode.  Of course then you have to see all the debug messages. I personally prefer the extra spam to resetting my UI Preferances for WoW-Pro every login.  Sadly, Ludo hasn’t yet been able to fix why it happens in non-debug mode.

  • img
    moonlight69
    Oct 23, 2016 @ 7:54 am

    Another oneI’m having this same problem. Every time I come back to the game, I have to reset my formatting from level 2 and 1 guide step, as well as reselecting the current guide I’m working on from the guide list (which also won’t open using the right-click menu, I have to manually find it under the addons in interface). I’ve tried setting up custom settings to fix this, and no luck, it always resets every time.

  • img
    kxmc65
    Oct 6, 2016 @ 20:35 pm

    Same Problem?I’m on 7.0.3Q. I think I have the same/similar problem.  Every time I log out, all formatting is reset and all profiles reset to default. I try to copy into different profiles to see if one will remain, but still all erased on login. Anything I might be doing wrong, or should I try going back a version or is there a beta?  Thanks for your awesome guides and helpful community.

  • img
    shadeblade
    Oct 5, 2016 @ 15:16 pm

    general bug with addonWith the new expansion my addon has begun to reset its displays and guid im using each time i log in and out.

  • img
    Sep 1, 2016 @ 13:25 pm

    Re: 7.0.3N WoWPro_Selector.lua line 245 ErrorI fixed your problem in https://github.com/Ludovicus/WoW-Pro-Guides/commit/f2740f7afa85ed551acc705e2e8265dcfaf4723bYou can download the developer version of the addon at https://github.com/Ludovicus/WoW-Pro-Guides/archive/master.zip until we vut the next release. 

  • img
    Ookami.kun
    Sep 1, 2016 @ 4:04 am

    7.0.3N WoWPro_Selector.lua line 245 ErrorUpdated to the newest version and am getting the following error upon logging into the game. Date: 2016-08-31 21:59:14ID: 1Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro_Selector.lua line 245:   attempt to index field ‘?’ (a nil value)Debug:   (tail call): ?   WoWProWoWPro_Selector.lua:245:      WoWProWoWPro_Selector.lua:241   (tail call): ?   [C]: ?   [string “safecall Dispatcher[1]”]:9:      [string “safecall Dispatcher[1]”]:5   (tail call): ?   …ceAddOnsArchyLibsAceBucket-3.0AceBucket-3.0.lua:118: func()   …sAckisRecipeListlibsAceTimer-3.0AceTimer-3.0.lua:55:      …sAckisRecipeListlibsAceTimer-3.0AceTimer-3.0.lua:48Locals:NoneAddOns: 

  • img
    Aug 18, 2016 @ 22:30 pm

    Re: 7.0.3L GetBuildings errorSorry about that.  I have a fix I’ll push out later today.

  • img
    Aug 18, 2016 @ 22:29 pm

    Re: Getting this error constantly, no other addons running. 7.03Sorry about that.  I have a fix I’ll push out later today. 

  • img
    Optimoos
    Aug 18, 2016 @ 1:17 am

    7.0.3L GetBuildings errorGetting this error on Alliance toon while using Shadowmoon Valley@Draenor guide and in Shadowmoon Valley. I’m on step 314, the issue started happening a few steps ago: Message: InterfaceAddOnsWoWProWoWPro_Broker.lua:975: Usage: GetBuildings(garrisonType)Time: 08/17/16 17:10:58Count: 11Stack: (tail call): ?(tail call): ?[C]: in function `GetBuildings’InterfaceAddOnsWoWProWoWPro_Broker.lua:975: in function `NextStep’InterfaceAddOnsWoWProWoWPro_Parser.lua:808: in function `RowUpdate’InterfaceAddOnsWoWProWoWPro_Broker.lua:319: in function `rowContentUpdate’InterfaceAddOnsWoWProWoWPro_Broker.lua:351: in function <InterfaceAddOnsWoWProWoWPro_Broker.lua:274>(tail call): ?[C]: ?[string “safecall Dispatcher[1]”]:9: in function <[string “safecall Dispatcher[1]”]:5>(tail call): ?…aceAddOnsGridLibsAceBucket-3.0AceBucket-3.0.lua:118: in function `func’…AddOnsElvUILibrariesAceTimer-3.0AceTimer-3.0.lua:55: in function <…AddOnsElvUILibrariesAceTimer-3.0AceTimer-3.0.lua:48>Locals: <none>

  • img
    Fry
    Aug 17, 2016 @ 13:59 pm

    Getting this error constantly, no other addons running. 7.03LMessage: InterfaceAddOnsWoWProWoWPro_Broker.lua:975: Usage: GetBuildings(garrisonType)Time: 08/17/16 06:55:54Count: 1Stack: (tail call): ?[C]: in function `GetBuildings’InterfaceAddOnsWoWProWoWPro_Broker.lua:975: in function `NextStep’InterfaceAddOnsWoWProWoWPro_Parser.lua:808: in function `RowUpdate’InterfaceAddOnsWoWProWoWPro_Broker.lua:319: in function `rowContentUpdate’InterfaceAddOnsWoWProWoWPro_Broker.lua:351: in function <InterfaceAddOnsWoWProWoWPro_Broker.lua:274>(tail call): ?[C]: ?[string “safecall Dispatcher[1]”]:9: in function <[string “safecall Dispatcher[1]”]:5>(tail call): ?…OnsWoWProLibrariesAceBucket-3.0AceBucket-3.0.lua:118: in function `func’…ddOnsWoWProLibrariesAceTimer-3.0AceTimer-3.0.lua:55: in function <…ddOnsWoWProLibrariesAceTimer-3.0AceTimer-3.0.lua:48>Locals: <none>

  • img
    Aug 10, 2016 @ 20:26 pm

    error messageIs there anything else as a clue to which guide it is.Based on the QID Im guessing its in a Garrison Guide, but I havent been able to find it on the site?  I found that line in the garrison campaign guide and it has been fixed. Per the change log, it looks like someone has been working on that guide lately and lots of changes to it.  So… hopefully, the current version should be good to go.   

  • img
    GrayMatter4tw
    Aug 7, 2016 @ 5:58 am

    Error upon login on any characterSince the most recent update, whenever I login to a character I get the following error message:WoWPro: 180:Duplicate tag |Z| in [FNagrand|QID|35985|ACTIVE|35985|Lunarfall|M|45.76.50.8|Z|Lunarfall|N|Use the chatoption|FACTION|Alliance].

  • img
    Jul 29, 2016 @ 7:40 am

    fixed on websiteI fixed it on the website, but it will not be fixed in the addon until Ludo makes a new build. (and updates guide files)If you want to fix it on your install before that, you can open the guide file and insert a “|” between the numbers and Korelock (i.e. 12292|Korelock).  The guide file is found in the wowpro_levelingalliance directory.

  • img
    lownignitus
    Jul 27, 2016 @ 14:22 pm

    same 3 error messages spam fill my chat when doing Grizzly hillsWoWPro: Malformed QID [12292Korelock ] in Guide JamGriA7577WoWPro: Malformed QID [12292Korelock ] in Guide JamGriA7577WoWPro: Malformed QID [12292Korelock ] in Guide JamGriA7577 I am using wow-pro 7.0.3H on an alliance toon. My chat has those 3 line repeating about every second when I have that guide selected and it fills my chat frame up with that spam. Only way to make it stop is to turn guide off.

  • img
    Jul 26, 2016 @ 2:49 am

    Re: Shadowmoon valley and Frostfridge ridge guides breakingCan you post a debug log?

  • img
    Jul 26, 2016 @ 2:47 am

    Re: Russian symbols did noot showI must confess I have never tried the client in Russian, since I only know latin alphabet languages.But, I can clearly see that the ??? characters should be something else.Let me see what I can do.  Did you ever use our Addon in Russian and succeed or is this your first time using it?—Ludovic

  • img
    Jul 26, 2016 @ 2:42 am

    Re: WowPro addon lua errors upon loginFixed in the next release tomorrow.

Leave a Reply

Your email address will not be published.

Categories

Archives