LATEST NEWS

WoW-Pro Addon Community Page

img
Nov
30

 

 

 







  • img
    Nov 9, 2014 @ 14:33 pm

    Starseeker Shamed me into doing itSo I finally updated the bug page.I’m embarassed at how easy it was once I figured it out.

  • img
    Nov 9, 2014 @ 12:42 pm

    reporting bugsI apologize for not having updated the bug pages.   It is one of those todo tasks that always falls to the bottom.Anyways, post the bug at the bottom of the source code pages: The most general one is: https://wow-pro.com/node/3196The Pandaria one is: https://wow-pro.com/node/3596The Krasarang pages are: Alliance at https://wow-pro.com/node/3488 and   Horde at https://wow-pro.com/node/3489Blizzard is always changing quests and we always need to adjust guides. Please be sure to specifiy which version of the addon you are running and if you can

  • img
    starseeker
    Oct 30, 2014 @ 21:27 pm

    Some quests have to be manually checked offI am having some issues with quests in Krasarang Wilds not auto updating when I finish them, and then when I manually check them off (right click) and reload or come back to the area, the setting isn’t remembered and I have to check them off again.Specifically:* Unga Fish Getter prompt (to pick up Confusing Treasure Map)* Raid Leader Slovon quest* Thieving Raiders quest (ID 30168)I took a look at the raw addon data and wowhead data and I’m not sure what’s wrong with Thieving Raiders – maybe it’s because the quest items aren’t an item in your bags anymore? Hopefully that’s something you’ve seen and know how to deal with.Is this the right way to report issues like this? The report bugs in specific guide page button above doesn’t seem to contain the guides from pandaria onward. I like this addon so much 🙂 I’d like to help where I can reporting things.

  • img
    Oct 16, 2014 @ 1:35 am

    Re: Error in 6.0.2Message: InterfaceAddOnsWoWProWoWPro_Broker.lua:855: attempt to index global ‘QuestLogFrame’ (a nil value)This error indicates that you are using an old version of the addon.  Please upgrade to the newest version!

  • img
    Oct 15, 2014 @ 23:19 pm

    error are you using the newest version of wow-pro. (6.0.0 posted 10/14/14) ? A new version will be posted later today (or perhaps early tomarrow) for some errors identified. If the error persists please let us know what version of the addon you are using.

  • img
    Oct 15, 2014 @ 4:45 am

    Error in 6.0.2Hi there,

    The leveling addon is not functioning in 6.0.2. – Please see the specific error below.

    Message: InterfaceAddOnsWoWProWoWPro_Broker.lua:855: attempt to index global ‘QuestLogFrame’ (a nil value)
    Time: 10/14/14 20:40:19
    Count: 1
    Stack: (tail call): ?
    InterfaceAddOnsWoWProWoWPro_Broker.lua:855: in function `PopulateQuestLog’
    InterfaceAddOnsWoWProWoWPro_Parser.lua:430: in function
    (tail call): ?
    [C]: ?
    [string “safecall Dispatcher[1]”]:9: in function
    (tail call): ?
    …InventoryExternalsAce3-AceBucketAceBucket-3.0.lua:118: in function `func’
    …sAckisRecipeListlibsAceTimer-3.0AceTimer-3.0.lua:55: in function

    Locals:

    Hoping some of you still play and can update this.

  • img
    Nov 29, 2013 @ 17:18 pm

    Re: I already started one for theAn alternative approach is not to write a guide that stands on its own, but one that works in conjuction with another addon.http://www.wowace.com/addons/npcscan/ is great at finding and targeting the rares, but we would need to provide a flight plan.Hmm, come to think of it, http://www.wowace.com/addons/npcscan-overlay/ has the creature paths in a DB.  Maybe we could tap into it and generate a path to follow.Then we could just take care of tracking the achivements and showing the flight route to take.

  • img
    Nov 29, 2013 @ 7:38 am

    I already started one for theI already started one for the Outland achievement until I realized that the rares there are not as “guide-friendly” as those in Pandaria are. What I mean by that is that the rares in Pandaria are mostly sitting idly in one spot or else patrolling in a small area that is relatively quickly scouted for their presence. The rares in Outland often roam across the entire zone they are in, with their respective paths even overlapping, so we can’t use WoWPros targeting function as it can only target ONE rare at a time and if one of the other rares happens to be there, we’d miss it. Alternatively, the guide would have to have players flying across the same zone three or four times.A good example of what I mean are the three rares that can be found on Hellfire Peninsula, just look at the maps: Voraken Doomspeaker, Mekthorg the Wild and especially Fulgorge.When I saw what an insane amount of work both writing AND following a guide for that would be, I kind of gave up 😉

  • img
    mermel
    Nov 27, 2013 @ 4:55 am

    Guide RequestLooking for anyone smarter than me (and with more time) to create a guide for the rare achievements in Outland and Northrend, similar to Glorious!  Anyone up for it?

  • img
    Nov 18, 2013 @ 17:09 pm

    Multi Coordinate StepsAuto clearing steps on coordinates, has something broken, going through the Wandering Isles starting zone, I’m finding the coordinates of the first coordinate shows, but doesn’t move to the next coordinate when you get near them.

  • img
    Oct 12, 2013 @ 19:01 pm

    Re: I got the message “Unable toUggh, more site admin work.Why dont you send me something on curseforge or GitHub instead. 

  • img
    Oct 6, 2013 @ 11:36 am

    I got the message “Unable toI got the message “Unable to send e-mail. Please contact the site administrator if the problem persists.” as well as a success message – let me know if you didn’t get it.

  • img
    Sep 28, 2013 @ 1:14 am

    Re: Backslash NDrop me an email with more details on what you want to work.I’m sure I can make it work! 

  • img
    Sep 24, 2013 @ 22:17 pm

    Backslash NUsing Backslash N works great on the step window, but doesn’t in the Current Guide window, any chance this can be fixed for the Current Guide window?

  • img
    Jul 30, 2013 @ 17:05 pm

    should be solved with latestshould be solved with latest version now

  • img
    raggaren1994
    Jul 10, 2013 @ 21:46 pm

    I’ve got the same problem butI’ve got the same problem but for all the guides on all races, sort of annoying

  • img
    MrBackpack
    Jun 8, 2013 @ 1:06 am

    I’ve got the same problem. ItI’ve got the same problem. It isn’t just on one character either, its on all of my characters.

  • img
    dommiel
    May 28, 2013 @ 15:23 pm

    wowpro causes game to crashI’ve updated all addon and by a process of elimination it is definitely wowpro that is causing wow to crash.  Would reverting to an earlier version fix the problem as the latest version cannot be used.  I’ve been trying to get any response for several days but everything goes into the black hole of pre-moderation.

  • img
    Refrayin
    Mar 27, 2013 @ 4:26 am

    GoTo waypoints not being removedI’ve used the WoW-pro guide addon since about the time of its release. However, some months ago i started having a problem. Whenever i complete a step without walking exactly on the spot of a waypoint, the waypoint will not be removed. So if i don’t constantly clear my waypoints i’ll have a bunch of waypoints for no reason. I’m using Carbonite, and I’m unsure whether it is carbonite borking up or the guide addon. It worked earlier, so I’m at a loss. 

  • img
    Refrayin
    Mar 27, 2013 @ 3:15 am

    GoTo waypoints not being removedI’ve used the WoW-pro guide addon since about the time of its release. However, some months ago i started having a problem. Whenever i complete a step without walking exactly on the spot of a waypoint, the waypoint will not be removed. So if i don’t constantly clear my waypoints i’ll have a bunch of waypoints for no reason. I’m using Carbonite, and I’m unsure whether it is carbonite borking up or the guide addon. It worked earlier, so I’m at a loss. 

  • img
    andyarnolduk
    Feb 19, 2013 @ 18:23 pm

    Changing the semicolon didn’t workOK, I’ve tried picking up the Burning Vengeance quest again after changing the semicolon to a comma and it didn’t clear the step.  I’ve abandoned the quest again, just in case you have any other suggestions for testing the guide. CheersAndy

  • img
    andyarnolduk
    Feb 19, 2013 @ 16:50 pm

    Something to try…I haven’t got anyone of the right level either 🙁 Thanks for the suggestion… I’ve edited the file and replaced the semicolon with a comma as suggested, and have reset the guide.  Unfortunately, this alt had already completed the “Burning Vengeance” quest; so the only thing that the reset did was to show the initial “Accept” step again.  But as I’ve already completed it, I can’t pick up the quest from the giver. I’ll check some of my higher level toons to see if they’ve done this quest and if so, I’ll run them through it. 🙂 CheersAndy 

  • img
    andyarnolduk
    Feb 19, 2013 @ 16:40 pm

    I don’t think so… I don’tI don’t think so… I don’t remember seeing an error message like that in the chat window.  It just didn’t tick the step off as completed. Andy

  • img
    Feb 19, 2013 @ 12:08 pm

    Re: OK, I’m running a HumanHmm, Did you get an error message like:Expected QID nil, found XXX instead on quest [Burning Vengeance] ?It looks like the leveling addon has incomplete support of multiple QUIDs.I’ll put it on my list! 

  • img
    Feb 19, 2013 @ 9:45 am

    Yes, it is a bug in theYes, it is a bug in the guide, one that I reported ages ago (see my comment on the guide page: https://wow-pro.com/node/3265 ), but apparently no one could think of a fix for it.

  • img
    Feb 19, 2013 @ 2:58 am

    something to trySince I don’t conveniently have someone of the right level to test this… Can you try changing the “;” to a “,” on your copy of the guide? It is located in your wow directory (..interfaceaddonswowpro_levelingalliance50_52_Crackerhead22_burning_steppes.lua) .  Then let us know if that solves the problem and it checks off properly (automatically).

  • img
    andyarnolduk
    Feb 17, 2013 @ 18:39 pm

    OK, I’m running a HumanOK, I’m running a Human Hunter through the Burning Steppes guide in the addon and have just accepted the quest “Burning Vengeance”. Unfortunately the guide doesn’t seem to have updated the “Accept” step below:  A Burning Vengeance|QID|28416;28174|M|17.31,51.98|N|From John J. Keeshan.| I can see from Wowhead that there are 2 Alliance quests called “Burning Vengeance” but with different IDs (as shown in the line of code above) I have QID 28174 in my quest log.  What I don’t understand is…. the semicolon in the code above separates the 2 QIDs, and I’m assuming that should allow either of the 2 quests to “Accept” and complete that step in the guide.  But it hasn’t, and the “Accept” step is still not completed and is visible in the addon. Obviously, I can just right click the step to complete it, but I was wondering if this is a bug with the Burning Steppes (Alliance) guide?  Or is it something in the addon code that needs tweaking? CheersAndy

  • img
    Dec 31, 2012 @ 4:00 am

    same for worgan. presumablysame for worgan. presumably all mages.  Prolly should be reworded to say learn the spell offored… so when Bliz changes it up again, we won’t have to.

  • img
    treylw89wow
    Dec 28, 2012 @ 10:54 am

    hope its right placeI wouldnt call it a bug but didnt know where to put it.for quest 11/146 for a human mage The note says “learn arcane missles”the vanilla quest is “learn frost nova”i just thought i’d share.hope im not bugging you guys pointing out something small. love the addon its great hope to see a skinning guide soon :]

  • img
    Dec 2, 2012 @ 12:42 pm

    Re: new bug fixOK.  Development version now has the friendship crash fixed.Started playing the tillers guide, but I gotta take an eye break.

  • img
    Dec 2, 2012 @ 11:37 am

    Re new bugYup, debug code.  And in this case, it panned out!It means that I probably have the return values from the new function slightly off.I’ll tweak again.  

  • img
    Dec 2, 2012 @ 3:26 am

    new bugI dl’d (and installed)  the newest patch you put on github today.   I opened my tillers guide and when accepting the quest in this step (2nd step of dailies – after the intro)A A Gift For ??|QID|30470;30471;30472;30473;30474;30475;30476;30477;30478;30479|PRE|30257|M|52.70,50.47|N|From Andi.|The quest specifically was A Gift for Gina|QID|30479
    The step after it is :B Buy or Make 5 Valley Stir Fry|QID|30470;30471;30472;30473;30474;30475;30476;30477;30478;30479|REP|Chee Chee;1277;Stranger-Good Friend|L|74647 5|N|This is for Chee Chee It requires Reef Octopus x5 and Wildfowl Breast x5.|;30402and is presumably the problem? (since it uses the friendship logic)I got the error shown below (but with a whole long list of addos).  I then exited wow, turned off that whole long list of addons, and had JUST wow-pro. wow-pro dailies and tom tom.  At that point only the First N step of the guide would load.  I also tried a differant guide (golden lotus) and only the first N step of that guide would load alsoNext I turned on wow-pro leveling and the whole guide would load, but it still wouldnt advance past the step A gift for ??Next I logged out again and turned on swatter, thus getting the same error without the whole long list of addons. (shown below)Also of note…When I log back in (or /reload) the steps that should be compete at this time (i.e. A Get all quests from farmer yoon, and A A gift for ?? from Andi) are not checked off.  I am not surprised that the one from Andi is not checked since it is what threw the error, but the first step, (get all from farmer yoon) worked fine and I do indead have one of the quests listed in my quest log.

    Date: 2012-12-01 17:01:07ID: 1Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro.lua line 56:   bad argument #3 to \'format\' (string expected, got nil)Debug:   [C]: format()   WoWProWoWPro.lua:56: Print()   WoWProWoWPro_Broker.lua:316: NextStep()   WoWProWoWPro_Broker.lua:376: NextStepNotSticky()   WoWProWoWPro_Mapping.lua:340: MapPoint()   ...faceAddOnsWoWPro_DailiesWoWPro_Dailies_Parser.lua:435: CheckFunction()   ...faceAddOnsWoWPro_DailiesWoWPro_Dailies_Parser.lua:439:      ...faceAddOnsWoWPro_DailiesWoWPro_Dailies_Parser.lua:438Locals:(*temporary) = \"%s: Rep %s Friendship=%s: repID %s <= standingId %s and repmax %s >= standingId %s and Replevel %s == 0\"(*temporary) = \"WoWPro\"(*temporary) = nil(*temporary) = \"true\"(*temporary) = \"0\"(*temporary) = \"31290\"(*temporary) = \"4\"(*temporary) = \"31290\"(*temporary) = \"0\"(*temporary) = \"string expected, got nil\"AddOns:  Swatter, v4.0.6 (<%codename%>)  TomTom, vv50100-1.0.1  WoWPro, v2.4.0  WoWProDailies, v2.4.0  WoWProLeveling, v2.4.0  BlizRuntimeLib_enUS v5.1.0.50100 <us>  (ck=a3)

    More to add. I then went to do the Golden Lotus Dailies and got the following x3 (as in 9 total lines in my chat box) upon opening the guide. and upon each time I accepted a quest. They appear to check off right tho.

    WoWPro: Rep The Golden Lotus Friendship=false: repID 6 = standingid 5 Replevel 0 == 0
    WoWPro: Rep The Golden Lotus Friendship=false: repID 7 = standingid 5 Replevel 0 == 0
    WoWPro: Rep The Golden Lotus Friendship=false: repID 8 = standingid 5 Replevel 0 == 0

    looks like debug code?

  • img
    Dec 1, 2012 @ 13:43 pm

    RE: API ChangeYeah, I was working on it,   There is a change in the developer area:https://github.com/Jiyambi/WoW-Pro-Guides/archive/master.zipThat should fix it.  Please try it out and if it works for both Tillers and regular reps, then I will issue a new release. PS:  There is some debug messages that will print that will tell me things I need to know if it does NOT work right. 

  • img
    Dec 1, 2012 @ 3:33 am

    API ChangeThanks for the heads up.  I put a correction up for Ludo to look at. Hopefully it all works 😉 

  • img
    Bishop
    Nov 30, 2012 @ 4:18 am

    Reputation API ChangeI submitted a bug report about 20 minutes ago and then dug into
    things a bit more and figured out what seems to be going on. I was
    having trouble with the Terrokar guide tonight, where it wouldn’t show any
    but the “pick a faction in Shattrath” line items (two of them). Looked
    back at a bug that had popped up upon login, and realized it referenced not
    finding the “GetFriendshipReputationbyID” API call.Unfortunately,
    looks like this call has been removed in patch 5.1, and there’s a new
    “GetFriendshipReputation” API call. It’s not a direct
    replacement since they have added in a couple of new return values in the new function.This apparently directly affects Terrokar since a lot of the available quests are dependent on whether you’ve got Aldor or Scryer rep. 

  • img
    Nov 7, 2012 @ 9:25 am

    Everyones install of wow mayEveryones install of wow may be in a differant place. the C:public… is just an example. Where you want to extract them to is where ever your WoW directory is … ie for you C:program file(x86)world of warcraftinterfaceaddons What about your install isnt working?

  • img
    steveperry9999
    Oct 27, 2012 @ 5:26 am

    I am having an issueI am having an issue installing the WOW Pro and TOM TOM add-ons.  Unless I read the troubleshooting questions wrong then I think something is messed up.  I don’t have the path C:UsersPublicGames.   I tried extracting them to C:Program Files (x86)World of Warcraft.   I extracted them while they were saved inside the file.  What am I doing wrong because I don’t have that path?  By the way WIN 7 Enterprise, Alliance

  • img
    Oct 24, 2012 @ 22:39 pm

    RE: Website bugJiyambi has given me Admin powers.   I can now see the temp file settings and I can see how many security updates and other horrrible things need to be done.I am glad you can edit, I was looking to upgrade you and was confused as it seemed that you should be able to! 

  • img
    Oct 24, 2012 @ 8:03 am

    So how did you get a profileSo how did you get a profile picture then? I couldn’t find an option to link a pic from a filehoster… Or was uploading allowed at some point in the past?

  • img
    Oct 23, 2012 @ 19:07 pm

    RE: Website bugI was hoping, when I saw Snowflake on yesterday (and my permissions were changed.. yay! I can edit now!!) that the picture thing would be fixed too.  I also tried to upload a pix, but no such luck

  • img
    Oct 23, 2012 @ 15:00 pm

    Re: Website bugYeah, no uploads of pictures are allowed.
    Otherwise, I would have nice pictures for all the guides on the source page.
    Which reminds me, I need to beg the website admin to let me fix it.
    Sigh.

  • img
    Oct 23, 2012 @ 8:57 am

    Website bugItried uploading a profile picture, but the website gave me this set of errors:

    warning: realpath() [function.realpath]:
    open_basedir restriction in effect. File(/tmp) is not within the
    allowed path(s): (/home/wowpro) in
    /home/wowpro/public_html/includes/file.inc on line 188.warning: realpath() [function.realpath]:
    open_basedir restriction in effect. File(/tmp) is not within the
    allowed path(s): (/home/wowpro) in
    /home/wowpro/public_html/includes/file.inc on line 188.warning: realpath() [function.realpath]:
    open_basedir restriction in effect. File(/tmp) is not within the
    allowed path(s): (/home/wowpro) in
    /home/wowpro/public_html/includes/file.inc on line 190.warning: file_exists() [function.file-exists]:
    open_basedir restriction in effect.
    File(/tmp/estes_ava_draenei_small.jpg) is not within the allowed
    path(s): (/home/wowpro) in /home/wowpro/public_html/includes/file.inc on
    line 304.warning: move_uploaded_file() [function.move-uploaded-file]:
    open_basedir restriction in effect.
    File(/tmp/estes_ava_draenei_small.jpg) is not within the allowed
    path(s): (/home/wowpro) in /home/wowpro/public_html/includes/file.inc on
    line 615.File upload error. Could not move uploaded file.

  • img
    Oct 12, 2012 @ 21:08 pm

    Professions UpdateMy fault.  I’ve got the module re-coded but it takes a total re-write of all the different professions to make it work.  Plus, Blizzard thought they should make them easier to get levels so am having to rework that code as well.  Work has also kept me busy and i haven’t been able to put in as much time as I wished.  I think what I will do is just put out what I have and update the professions as I finish them.

  • img
    Oct 10, 2012 @ 21:12 pm

    took me a while to find it…took me a while to find it… but …as you will note at https://wow-pro.com/node/3499the professions module is still not working correctly.

  • img
    Lovutar
    Oct 10, 2012 @ 19:55 pm

    Professions Guide.Professions don’t seem to work, all i seem to get is goto trainer and get skill, if you click through that it just says to get the next skill, it doesn’t actually tell you what to skill up on, am i missing something or are these broke?

  • img
    samimw19
    Oct 6, 2012 @ 5:41 am

    the floating arrowwhen i died i lost my arrow….i have no idea on how to get it back iv looked everywhere. please help haha  

  • img
    Merlin955
    Oct 5, 2012 @ 17:27 pm

    Thank youThanks you for looking at this so rapidly.

  • img
    Oct 3, 2012 @ 22:04 pm

    Your request for the feature revealed a bugI noticed that hiding the guide during instances was also broken.I have coded up the pet batltles hider and fixed the instance hider.It will be in the next release.

  • img
    Oct 3, 2012 @ 20:55 pm

    Re: Hide guide during pet battlesHmm, Good Idea.   Using the super secret “/etrace start” command and then doing a pet battle yields the following useful events: PLAYER_CONTROL_LOSTPET_BATTLE_OPENING_STARTPET_BATTLE_ACTIION_SELECTEDPET_BATTLE_PET_ROUND_RESULTSPET_BATTLE_PET_CHANGEDPLAYER_CONTROL_GAINEDPET_BATTLE_FINAL_ROUNDPET_BATTLE_OVERPET_BATTLE_CLOSESo it looks like the PET_BATTLE_OPENING_START and PET_BATTLE_CLOSE events can be used to bracket the hiding.I’ll confirm and implement.

  • img
    Merlin955
    Oct 3, 2012 @ 18:43 pm

    Hide guide during pet battlesWould it be possible to add the abilty to hide the guide during pet battles?  I keep the guide near the top of the screen and it overlaps the pet battle info panel.Thanks

Leave a Reply

Your email address will not be published.

Categories

Archives