LATEST NEWS

WoW-Pro Addon – Patch 3.2

img
Aug
05

Update: The WoW-Pro addon should now work correctly if you follow these steps:

  • Download the update to Tour Guide and extract it into your addon folder.
  • Download the update to TomTom and extract it into your addon folder.
  • Download the update to Lightheaded and extract it into your addon folder.
  • On the character selection screen, select “Load out of date addons” (for now our guides are listed as out of date, but they still work fine. This will be fixed soon)

Please let us know if you still have trouble after following these steps!

Thanks to everyone who left feedback, and sorry that it took me a while to respond… I may or may not have been screwing around in WoW with my new cat form 🙂

  • img
    Jabjaws65
    Jul 18, 2010 @ 16:58 pm

    Lightheaded addon ProblemI read about Wow-pro when looking for leveling guides and thought “wow!” I was able to download and unzip everthing and put it in the addon folder. Everything showed up but Lightheaded on the addon interface in the game. I deleted and did it again 3 times and even redownloaded the zip and did that again. It is still not showing up. I am pretty sure its in the right place because Tom Tom and Wow-pro showed up and are working fine. I just dont have an arrow to help with navigation. Quest helper is disabled. Any suggestions or other options to get the arrow? Thanks Milagros 😕

  • img
    Anonymous
    Jan 4, 2010 @ 7:59 am

    still not workinghi
    im a DK and iv downloaded the latest updated tour guide but is still dont work for me sorry to tell that

  • img
    Oct 1, 2009 @ 4:41 am

    Awesome, I’m really gladAwesome, I’m really glad that worked! Have fun with the addon 🙂

  • img
    BakaX
    Oct 1, 2009 @ 4:05 am

    Worked?!well its a miracle I had to re install everything 2x then load up every addon cept questhelper and then disable carto or tomtom ( which ever one you dont want to use) and enable the add on you would like to use. This is what I did to get the white box go away.

    PS if you need a detailed explantion on what to do…just pst me or something similiar.

  • img
    Sep 28, 2009 @ 6:13 am

    Hmm, well first off IHmm, well first off I definitely recommend using Cartographer’s arrow (that is, if we can get it to work) – I’ve heard of some issues with TomTom that seem to be cleared up when people use Cartographer. Unfortunately this doesn’t seem to be one of them. You’ve probably tried this, but if not, try loading the game without TomTom and Questhelper loaded, with Cartographer, Tour Guide, Lightheaded, and our guides. Try turning off all other addons, just to make sure it’s not some weird addon conflict.

    I’ve seen the “white box” you talk about, usually only for a minute though until Cartographer figures out what the heck it’s doing. Unfortunately I don’t know what would cause it to become a permanent issue. Has anyone else had this problem and found a fix for it?

    EDIT: Also, have you tested other sections of the guide to see if maybe it’s just the one? Or tried other characters?

  • img
    BakaX
    Sep 28, 2009 @ 3:38 am

    Almost forgotI can see the QuestHelper arrow but not cartographer, and tomtom’s only when I set a waypoint which is very very strange to me. Re installed all of them again, no luck. Deleted Cache, and Wtf, no luck. Deleted guides + add ons, no luck. Lost!!!! SOS ( save our characters!) from no james guide that is 🙁

  • img
    BakaX
    Sep 28, 2009 @ 2:46 am

    Yes, yes, and yesYes I have but alas its been around 14 hours now, I still can’t play going mad >=(
    I hate my life. I got this white box of death where the arrow used to be, not anymore since I re installed everything. not one add on that has the arrow has worked with me. Cartographer, TomTom, and even QuestHelper.

  • img
    Sep 27, 2009 @ 23:29 pm

    You probably already checkedYou probably already checked this but I gotta ask, have you checked the “Load out of date addohns” box? Our addon currently reads as out of date even though it is not, and the recent patch will have unchecked that box.

  • img
    BakaX
    Sep 27, 2009 @ 21:59 pm

    Confused and LostHeres my problem, before 3.2 I had errors but all I had to was check a box in the guide and I would get my arrow. Now I get nothing, I re-installed everything, updated everything, I used Cartographer and Tom Tom but even though no errors appear now I get no arrow, I have been at this for 8 hours so far and I’m so frustrated. My problem is your guides are to awesome that I wont go on with out them. So please help! 😕 🙁

  • img
    morikal
    Sep 2, 2009 @ 3:16 am

    Its a TomTom issueTomTom cannot create or display waypoints in the DK zone because its a “phased zone” or something like that. I believe cart WPs still work, and I know questhelper is able to muddle its way through (for the most part… its kind of messed up for some of the DK quests, but I don’t think that is a waypoint issue, I think its a bad data issue. I.e., sometimes QH directs you to go to the wrong place, or just sits on the questgiver and tells you to get what they want)

  • img
    Aug 27, 2009 @ 1:13 am

    It has not been. I plan toIt has not been. I plan to run through there after I finish my classic loremaster achievement and code it then, if no one else has by that time.

  • img
    Aug 27, 2009 @ 1:12 am

    Unfortunately, the DK zoneUnfortunately, the DK zone is not recognized (I’m not sure where this problem lies, it’s either with Tour Guide or TomTom). So there is no arrow for these zones 🙁

  • img
    Aug 27, 2009 @ 0:00 am

    Is the Shadowmoon guide onIs the Shadowmoon guide on here coded into the addon yet?

    Comment me on my blog. http://kostada.blogspot.com/

  • img
    Aug 26, 2009 @ 16:27 pm

    LUA Error?I know I saw the answer to this question somewhere on the site once before, but am having trouble locating it. 😕

    I am re-rolling an Alliance DK on the Velen server and while following the guide (tried a Hordie on a seperate server as well) everytime the quest box thingamajig (I don’t know the actual name.. but the box where the steps show up and tick off) ticks to the next quest, I get a pop-up telling me there is a LUA Error and a message in the chat box saying that the “zone isn’t recognized, using default zone”… Also, there is no TomTom Arrow…

    Any thoughts? lol

  • img
    Aug 24, 2009 @ 23:22 pm

    Ah, glad that’s the case andAh, glad that’s the case and it’s not some weird bug!

  • img
    Aug 24, 2009 @ 22:47 pm

    Thanks for the help Jiyambi.Thanks for the help Jiyambi. I do think the problem you stated was why – I’ve only used the addon a few times and my computer doesn’t like when I alt tab and I had to shut the game down without properly logging out.

    Comment me on my blog. http://kostada.blogspot.com/

  • img
    Aug 24, 2009 @ 22:38 pm

    Hmmm, it should be saved.Hmmm, it should be saved. This is probably a problem with the major tour guide addon and not our plug=in for it. Make sure you are logging out correctly and not force-quitting WoW (that doesn’t save changes) – though I’m assuming you are. Try looking up the bug on the Tour Guide download page to find a solution, unfortunately I don’t know what would be causing this or how to fix it 🙁

  • img
    Aug 24, 2009 @ 20:21 pm

    Loving the addon, however,Loving the addon, however, should the progress be saved when you log out? Because everytime I do and come back on it doesn’t and I have to reclick through my progress.

    Comment me on my blog. http://kostada.blogspot.com/

  • img
    Aug 20, 2009 @ 21:29 pm

    I’ve been told disabling andI’ve been told disabling and renabling has worked for some people. Try that and let me know. Also make sure all the tabs in your quest log are open.

  • img
    Aug 20, 2009 @ 18:40 pm

    Hosho’s Barrens GuideHey, I was working on my alt Pally, and being sick of Ghostlands, I brought him over the the Barrens to work through the teens there and maybe do a few WC runs.

    I am having the same issue on him as to where the guide won’t update as you go along. Apparently the problem is only with this toon, because my Hunter is currently workign off the same guide with no issue at all. Any suggestions?

  • img
    Aug 20, 2009 @ 8:05 am

    Dang it, I actually wasDang it, I actually was aware of this and forgot about it!

    This is *definitely* something we should put in the FAQ. Thanks very much for sharing the solution with us, and I’m glad it’s working now 🙂

  • img
    Hexxum
    Aug 20, 2009 @ 5:53 am

    Think I figured it out!Seems as if the SMV tab in my quest log was minimized and looks like thats what was causing the issues with TG updating!

    Just thought I would update if anyone else ever comes across this issue 🙂

  • img
    Asahunt
    Aug 20, 2009 @ 3:27 am

    Completely SoloableI solo’d him w/ my shaman after a couple tries. The trick is that you need to have something constantly on his aggro table through MCs so he doesn’t reset. For me this was my Spirit Wolves, but an Earth Elemental might work too. I had both my Fire Elemental and my Spirit Wolves out just in case.
    After you finish that phase, the rest is cakewalk because you still have the Worgen’s Blood buff.

  • img
    Aug 20, 2009 @ 1:20 am

    Jame’s Grizzly Hills, Horde v0.7 Hour of the WorgWas unable to solo Arugal as a shaman: when he goes down to 50%, he MCs the only opponent – me, and goes straight back to full health. Not sure this is possible any more (patch 3.2)

  • img
    Aug 20, 2009 @ 0:59 am

    Jame’s Grizzly Hills, Horde v0.7 Voices in the DustTurn in waypoint is wrong, should be (71.50, 26.00)

  • img
    Aug 19, 2009 @ 22:33 pm

    Thanks for the nice feedbackThanks for the nice feedback 🙂 Yeah, unfortunately it does sound like it’s a TourGuide issue. I heard some people have had success un-enabling and re-enabling the guide, when they encounter problems such as this. You might try that out.

  • img
    Hexxum
    Aug 19, 2009 @ 18:15 pm

    Yes, just realized it wasYes, just realized it was the default guides… but this issue seems to be happening with all of the tour guide guides, including the wow-pro ones. so it must be a TG specific issue as opposed to the wow-pro written ones.

    Ill go take a look at the TG forum and see if I can find out the issue. none the less, the james alliance leveling guide are excellent additions to the wow community!

  • img
    Aug 19, 2009 @ 11:07 am

    Hmmm, I’m fairly certain noHmmm, I’m fairly certain no Netherstorm or Shadowmoon Valley guide has been coded yet from WoW-Pro. Are you certain you are using our guides and not the default ones? All of our guide say “WoW-Pro” in the title. Are you using the Horde or Alliance version of the guide?

  • img
    Hexxum
    Aug 19, 2009 @ 6:16 am

    Shadowmoon Valley Guide IssueAll of a sudden, the guide does not update when I pick up a quest. It worked fine for me after 3.2 with the BEM and netherstorm guides. It happened when I moved to the SMV guide. If I manually check the box after I get the quest it automatically checks the quest finished “?” boxes as well.

    Any help is greatly appreciated! The addon is great, me and my DK love em!

    Thanks!

  • img
    Aug 19, 2009 @ 1:15 am

    Jame’s Grizzly Hills, Horde v0.7 Fate and CoincidenceThis quest turn-in spawns a waypoint at Arugal’s Tower and Camp Oneqwah in addition to the real coordinates (57.50, 41.0)

  • img
    Aug 19, 2009 @ 0:47 am

    Jame’s Grizzly Hills, Horde v0.7 Northern SalmonQuest helper text mentions the water is shallow, but as per today, all salmon schools I found was a bit further out, in deep water.

  • img
    Aug 18, 2009 @ 0:57 am

    Jame’s Grizzly Hills, Horde v0.7 waypoint* Turn-in waypoint for Samir at the end of “Filling the Cages” is located in Ghostlands instead of Grizzly Hills. should be Grizzly hills, 16.20, 47.68
    * Starter NPC for Scourgekabob (Prigmon): same issue, should be Grizzly Hills 15.75, 46.76
    * Starter NPC for Shimmercap Stew (Prigmon): same, see above for coords
    * Waypoint for Attack on Silverbrook points at 26,13 which is in ZD. Correct coords: 26,31

  • img
    Icenova
    Aug 12, 2009 @ 22:15 pm

    Tom Tom/Waypoint issuesOk i have no idea if this issue has already passed but after fiddling with thinks i solved my own problem and thought to post it here in case any one else was having my same issues.
    – a couple things to note is that i use the curse client for all my add-on needs, also i have both cartographer and tom tom installed, i had it where waypoints on cart’s end were disabled.

    – ok so after the curse client did its thing and updated every thing the add-on worked great, but i then started to realize a lot more of the waypoints were missing that what i remembered. so i blamed cartographer, upon disabling it the problem persisted… any ways that’s the general idea of the problem.

    i don’t know how much of these steps are necessary but just to be safe ill list them.

    1. I downloaded the new lightheaded(curse doesn’t support this add-on)
    2. before i installed lightheaded i logged out, unchecked tom tom from my add-on list then logged back in, then exited the game.
    3. installed the new lightheaded, started up game then went into cartographer’s settings and re-enabled waypoints and co-ordinates and then restarted the game one more time, after that iv been getting the waypoints i was previously not.

    Once again im sure a lot of this is unnecessary but i don’t wanna mess with anything to figure that out >_<

  • img
    Aug 11, 2009 @ 13:15 pm

    …edit: my mistake, addon is working fine for me 🙂

  • img
    Aug 11, 2009 @ 4:21 am

    I’m glad you got it working!I’m glad you got it working! 🙂

  • img
    1jesus1
    Aug 11, 2009 @ 3:57 am

    quest help guidesI finally figured out my problem. Addons were in one extra folder. Once I moved just the files/folders that were inside the main folder, into the Addons folder, everything is working again. 🙂

    thanks, sherry

  • img
    1jesus1
    Aug 11, 2009 @ 1:32 am

    quest help guidesVista Operating System

    when I add the updated files, I do remove the other one, right?

    thanks, sherry

  • img
    Aug 10, 2009 @ 19:13 pm

    What operating system areWhat operating system are you using?

  • img
    1jesus1
    Aug 10, 2009 @ 12:40 pm

    quest help guidesi downloaded the three patches for TomTom, Lighthead, TourGuide

    the unzipped files are in my addons, but i still don’t have them on the game

    i’ve got a headache……wish WOW would stop messing these up!

    Calmly waiting for an answer.
    sherry

Leave a Reply

Your email address will not be published.

Categories

Archives