LATEST NEWS

Patch 3.1.0 Addon Update

img
Avr
15

Update!

Thank you everyone for being patient, I know it’s very annoying not to be able to use the guides! Also, thanks to those who have helped by posting update links and temporary fixes.

If WoWInterface is still being buggy:

It looks like Cartographer *might* have a working update, but it may still have some bugs as well. Cartographer is a somewhat bulky map addon that provides an arrow just like TomTom’s, so if you folks are desperate to get it working again, this is an option. The newest version can be downloaded here.

From Maw:

As TomTom is not working, a thing you could do is to enable “waypoints” in the Cartographer menu. Then that waypoint function will make waypoint for you everytime a new coordinate appears in the guide. A red cross will also be shown at the map at the named location. You can also simply type /way xx,yy when you come to a new step and a new coordinate is mentioned in the guide, and then a waypoint will appear, though no red cross on the map.

  • img
    Avr 15, 2009 @ 8:16

    TourGuide 3.1.0 FixIf you’re feeling adventurous, you can update TourGuide yourself:
    1) Go to Start -> All Programs -> Accessories -> Notepad.
    2) Open “C:Program FilesWorld of WarcraftInterfaceAddOnsTourGuideBroker.lua”. (You may have to change “Text Documents (*.txt)” to “All files (*.*)”.)
    3) In the middle of the file, change “QuestWatch_Update()” to “WatchFrame_Update()”.
    4) Save. Then reopen WoW (if it’s already open, type /reloadui).

    Tekkub said he’s already made the change and will release a new version of TourGuide shortly.

    • img
      Avr 15, 2009 @ 8:38

      Thank you very much for thisThank you very much for this information! I hope you don’t mind, I’m going to shamelessly copy and paste these instructions into the above post. You rock!

      • img
        Ladyluck878 Répondre
        Avr 15, 2009 @ 8:42

        So BasicallySo basically we are to wait for the update. Any idea appoximately how long that might take? lol I havent had my fix today and am having heavy withdrawls.:P

        • img
          Avr 15, 2009 @ 8:44

          Heh, well you can try doingHeh, well you can try doing it yourself as freastro showed above. I imagine Tekkub will come out with the updated version sometime tomorrow at the latest (I hope!).

          Yeah, I abandoned WoW for the night to do homework. Stupid lack of guides (and completely bugged out Ulduar) making me be constructive! 😛

          • img
            Athromere
            Avr 15, 2009 @ 8:49

            About the fix..i did as you said and was i supposed to notice a difference or not? 😀 i also tried downloading the guides again after fixing tour guide and the guides still wouldn’t pop up. Am i doing something wrong or are both the tour guide and the jame guides themselves messed up atm? I guess cartographer is messed up too. Great. Any idea when these problems will be fixed and/or when cart will get updated? i havent heard much on that addon problem solving wise. Thanks for any info! 😀

          • img
            Avr 15, 2009 @ 9:05

            I’ll admit I haven’t triedI’ll admit I haven’t tried the fix myself, was just taking freastro’s word for it.

            Unfortunately, this kind of thing is really to be expected on patch day. It’s the same reason you should never schedule a raid for patch day (which my guild did anyway, and it didn’t end well…) – things are always buggy and nothing ever works quite right. It will take a short time for all the addon writers to catch up, but I’m almost certain everything will be sorted out by next week. I’ll keep you all posted, but if you find out anything before me, please share!

          • img
            Avr 15, 2009 @ 14:26

            Just wanted to say thatJust wanted to say that Tourguide released an update early this morning for 3.1 🙂

          • img
            Sammich
            Avr 15, 2009 @ 18:21

            Here is the link for the updatehttp://wow.curse.com/downloads/wow-addons/details/tourguide/download/344281.aspx

          • img
            Ladyluck878
            Avr 15, 2009 @ 9:08

            LolI didn’t understand any of the writing. Not a computer programmer, so it didn’t make sense to me. I’ll just wait *shurgs*. Not good at waiting,lol.

    • img
      blaider Répondre
      Avr 15, 2009 @ 9:22

      About the Update InstructionsI attempted to do the update and somehow, i’m not entirely sure, i managed to screw it up >.< :jawdrop:

    • img
      william702 Répondre
      Avr 15, 2009 @ 18:39

      It works great butIt works great but I can’t seem to get TomTom arrow thing to work. I have tried all the obvious stuff but its not working. Any tips on how to fix this as I find it very helpful/important whilst leveling.

      Thank you very much for all the info so far. 🙂

  • img
    Avr 15, 2009 @ 10:27

    Differences between TG and the regular guidesI have used Jame’s guides to level a number of toons. I have now tried the new add on version.

    First of all, the sequence of quests is not the same. In some cases, it is more efficient, in others less.

    For example, in the original allie guide for the Borean Tundra, you suggest jumping down the hole to get the escort quest. In the addon, you do the escort after getting the quest to kill the guy in the lake. This is an improvement.

    On the other hand the series of quests with the bots and the pumping station is not as well done as in the original written guide.

    This is just a comment. Thanks for the great work on both formats.

    Mavet, 80 DK on Boulderfist

    • img
      Avr 15, 2009 @ 20:12

      Admittedly I haven’t playedAdmittedly I haven’t played that particular portion of the addon guide, but are you sure you are using the WoW-Pro guide and not the default TourGuide guide?

  • img
    Mmadvo Répondre
    Avr 15, 2009 @ 17:07

    ………basterd………basterd wildhammer

    tourguide has been updated i use it now as we speak but i havent seen teh new update for tomtom yet keep up the good work jame

  • img
    Avr 15, 2009 @ 21:09

    As TomTom is not working, aAs TomTom is not working, a thing you could do is to enable “waypoints” in the Cartographer menu. Then that waypoint function will make waypoint for you everytime a new coordinate appears in the guide. A red cross will also be shown at the map at the named location. You can also simply type /way xx,yy when you come to a new step and a new coordinate is mentioned in the guide, and then a waypoint will appear, though no red cross on the map.

    This is a temporary solution which, atleast for me, works perfectly fine with Joana’s In-Game leveling guide. I’m not completely sure if this’ll work with TourGuide, but I think so.

    Hope this helps to someone that wishes to level on even under these rare conditions.

    EDIT: Make sure to have TomTom disabled when doing this.

    EDIT 2: Noticed after writing this that Jiyambi has already said some of this, if she didn’t add it (really fast) after I wrote this 😛

    • img
      Avr 15, 2009 @ 21:04

      Or download the TomTom BetaOr download the TomTom Beta from WoWInterface. This was the version he was making on the PTR. From what I’ve read its functional.

      —–
      all i want in life is to be happy!

      • img
        Avr 15, 2009 @ 21:16

        I’ve been trying to get ontoI’ve been trying to get onto WoWInterface all morning and getting lots and lots of server errors. I think they might be experiencing too much traffic with the patch issues going on.

        If you have a link for it, let me know, otherwise we’ll have to wait until I can get on there and find it >_<

        EDIT: Nvm, got onto the page shortly after posting this.

  • img
    Avr 15, 2009 @ 23:27

    Wowinterface is now workingWowinterface is now working properaly and I was able to download the new version of Tom Tom, I can confirm that it is now working properly, so you all can get back to your questing (Yay!).

    • img
      Ladyluck878 Répondre
      Avr 16, 2009 @ 2:14

      Interface maybe working but…Interface maybe working but I have downloaded the new TomTom and I can’t find my green arrow anywhere. I took out all the other TomTom folders and have just the r199. Unzipped, installed but can’t find an arrow. Please tell me what I did wrong,lol.

      Thanks

      • img
        Avr 16, 2009 @ 3:23

        Hmmm, I don’t use TomTom soHmmm, I don’t use TomTom so I’m not sure, but I know the newest version of Cartographer is definitely working with our guide, so you could try that if you really want to.

      • img
        Avr 16, 2009 @ 3:53

        I really have no clue what’sI really have no clue what’s wrong, but try this: Open up the folder where your addons are stored, look for “TomTom” delete it, and the .rar file that you extrated it from. Go to http://www.wowinterface.com and look for their list of updated addons, Jiyambi has a link on the front page download it, extract, you should have TomTom-rrsomthing as the title double-click that and you’ll see a folder that says “TomTom”
        right-click it and choose “cut”, then go to the folder hwre your addons are stored and paste it. If that doesn’t work then you’ll just have to rely on Cartographer, sorry if this wasn’t of any help to you.

        • img
          Ladyluck878 Répondre
          Avr 16, 2009 @ 4:11

          OMG I LOVE YOU, lolThank you so so so very much Arannar!! It fixed it and now I’m soooooooooooo Happy. Thanks again 😀 😀 😀

          • img
            Cuccii
            Avr 16, 2009 @ 9:45

            Where did u find urWhere did u find ur Addons?
            In the progam WoWMatrix itself?
            Pff im lvl 79 and i can’t get 80 without TomTom
            Arghhh!

          • img
            Avr 16, 2009 @ 10:52

            Heh, another reason whyHeh, another reason why WoWmatrix = fail!

            Where your addons are depends on what operating system you use. Check the installation section of [url=https://www.wow-pro.com/leveling_guides/james_horde_leveling_guide_addon]this page[/url] for the location of your addons, I don’t feel like typing it all out again. I will eventually get a FAQ up that shows this.

          • img
            Avr 16, 2009 @ 23:15

            I agree WoWMatrix is sooI agree WoWMatrix is soo fail 😛

  • img
    KirielKat Répondre
    Avr 16, 2009 @ 5:44

    Used the above download links but my version says v3.09.48Downloaded the above version of TourGuide but it still says v 3.09.48 when I check it. I even deleted the previous TourGuide folder and tried reinstalling from the above link.

    When I load WoW, I get an error saying:

    Message: ..AddOnsTourGuideBroker.lua line 70:
    attempt to call global ‘QuestWatch_Update’ (a nil value)

    Message: ..AddOnsTourGuideParser.lua line 81:
    attempt to perform arithmetic on field ‘current’ (a nil value)

    Not sure what I’m doing wrong! I even disabled every other addon besides tourguide but no luck. Anyone got any ideas?

    • img
      KirielKat Répondre
      Avr 16, 2009 @ 8:27

      Fixed. Apparently WindowsFixed. Apparently Windows Vista does not like to play nice. I finally moved my WoW folder to Public

      • img
        Avr 16, 2009 @ 8:29

        HAH! That was exactly what IHAH! That was exactly what I thought it was 🙂 Ignore my above post, you responded while I was typing.

      • img
        Cuccii Répondre
        Avr 16, 2009 @ 9:28

        And how do u doAnd how do u do that?
        Because i got the same problem 🙁
        And also i’m using Xperl and i can’t Rightclick on the target’s Lifebar/Mana So i Can’t trade or inspect or whatever 🙁

        • img
          Avr 16, 2009 @ 10:54

          For moving the WoW folder,For moving the WoW folder, Im not 100% if you can just move it, I think WoW asked me to do it at some point and I just clicked “OK”.

          The XPerl problem has been fixed in the most recent update (I use it as well), go to Curse and download the newest one to fix it.

          • img
            KirielKat
            Avr 16, 2009 @ 11:25

            Moving the WoW folderI just copied mine from Program Files. I went to UsersPublic and then created a folder called Games. Then copied and pasted the World of Warcraft folder over.

            so, you should get be in C:UsersPublicGamesWorld of Warcraft

            I left the old one in the Program Files just in case but it worked perfectly. Only problem is that I had to redo my interface.

    • img
      Avr 16, 2009 @ 8:29

      Hmmm, I know the above linkHmmm, I know the above link works, and at least according to the change log, it is version 3.1. What operating system are you using?

  • img
    BlizzardSucks Répondre
    Avr 16, 2009 @ 9:39

    Woo Hoo!Oh man I can’t live without these guides I’m so glad they’re back up. Woo Hoo~!

  • img
    RazmaX Répondre
    Avr 16, 2009 @ 13:21

    I downloaded the new versionI downloaded the new version of Tourguide but for some reaon I can’t get the wow-pro guides to load its still telling me they are out of date. Any fix for this? I did download them again that didn’t seem to help.

    • img
      Avr 16, 2009 @ 16:37

      At the character selectionAt the character selection screen, there is a button in the lower left-hand corner labeled “Addons”. Click it. There will be a screen that displays showing you a list of all your addons (and which ones are out of date). Select the checkbox at the top that says “Load Out-of-date Addons”.

      You can do that for all of your characters individually, or all at once in that screen.

      • img
        RazmaX Répondre
        Avr 16, 2009 @ 16:45

        ThanksThanks

  • img
    Avr 16, 2009 @ 13:52

    A Huge ThanksThanks a lot! I can’t live without them!

  • img
    Marillion Répondre
    Avr 16, 2009 @ 16:44

    ARRRRGHHHH…..OK, I have

    1. Deleted the old Tour Guide and downloaded the newest one available

    2. Deleted TomTom and downloaded the newest one available

    3. Deleted Lightheaded and downloaded the newest one available

    I have not seen a new Wow-pro guide to download for 3.1. The latest Wow-pro leveling guide that I have still shows as out of date in my add-ons screen. I tell the game to load it anyway. Tour Guide does NOT list and Wow-pro guides, neither in the interface tab under guides, nor when I right click the small tour guide HUD and select guides.

    Please help, because I’ve been doing my best to bug-test the latest version, but I WANT TO PLAY MY TOON!!!! 🙂

    • img
      Avr 16, 2009 @ 21:16

      Hmmm, the guides should loadHmmm, the guides should load based on what you’ve said. I’ve done the same things, and my WoW-Pro guides are loading fine. I’m on the Horde side. And I think I’ve heard it working for people on the Alliance side as well.

      I just don’t know what else to have you trouble-shoot from here, perhaps Jahwo can provide some insight.

      • img
        Avr 16, 2009 @ 21:57

        From the AllianceYes, it works for Alliance Guides as well, albeit with some strange behavior in TG. Bothing breaking though.

        My suggestion is to delete your WTF file after backing it up, then make sure that your config file was deleted as well.

        If that doesn’t work, and you are running Vista, make sure you have UAC turned off, install the addins to c:…/Username/Public/Games/World of Warcraft… etc. as WOW now draws from a different location in Vista.

        • img
          Avr 16, 2009 @ 23:25

          Great troubleshooting ideas,Great troubleshooting ideas, thanks!

      • img
        Marillion Répondre
        Avr 16, 2009 @ 23:59

        Uninstalled and re-installedUninstalled and re-installed again, finally got it to work, although it still lists as oudated. Back to the bug submissions!

        • img
          Avr 17, 2009 @ 1:10

          Yay! Unfortunately it willYay! Unfortunately it will be listed as outdated until we get an update from someone who knows more about Lua than I (probably Jahwo), but it should work fine despite that. Thanks for all the hard work, we really appreciate testers!

  • img
    SunDwarf Répondre
    Avr 17, 2009 @ 19:07

    Quest item buttonsThe guides load up fine for me, but i have another problem. When i try to press the button for the active quest’s item, nothing happens. This is ofc a small thing, but i really liked that i never needed to look in my bags for a quest item..

    • img
      Avr 17, 2009 @ 21:30

      Blizzard broke thisBlizzard broke this functionality when they added their own version of it. Your in game quest trackers should now have item buttons on it. You can also move the in game quest tracker around. The options are in your interface options menu somewhere.

      EDIT: Drat, Sixtel got to this before me! >_< 😉

    • img
      Sixtel Répondre
      Avr 17, 2009 @ 22:26

      Blizz’s new quest buttonBlizz now has a quest button to. Mine was hidden under one of my bars. This button worked for me and the old button no longer worked.

      “No one impedes us…no one denies us….and if need be….no one survives us…,”

      Edit:Yes but you phrased it better than me 🙂

      • img
        SunDwarf Répondre
        Avr 17, 2009 @ 22:22

        I found it, thanks guys.I found it, thanks guys.

  • img
    Seattle.Will Répondre
    Avr 22, 2009 @ 0:57

    Odd Problem…When I load the Tourguide addon and the Alliance Guide at the same time, the Tourguide itself disappears, and so does the green arrow. When I load only the Tourguide, it shows up but obviously is pointless since I cant use the guide.

    I deleted the old versions of Tourguide, TomTom, and Lightheaded, then re-installed the new ones, so I have no idea whats going on.

    • img
      Avr 22, 2009 @ 1:45

      That is a very odd problem.That is a very odd problem. Try opening the Tour Guide options under your interface options (use escape to get there). There should be a way to reset it to the default position, this might help. Otherwise, I’m out of ideas 🙁

  • img
    Vortex Répondre
    Avr 22, 2009 @ 12:55

    I have updated all theI have updated all the addons to the most current ones and now I can’t get any guides to load or Tom Tom to work. I get this error message “InterfaceAddOnsTourGuideParser.lua:88: attempt to call field ‘?’ (a nil value)”. Anybody know how to fix this problem?

  • img
    bazza Répondre
    Avr 22, 2009 @ 15:21

    patchhi there sorry bout my spelling but hear goes when i update the latest patch it runs to 70 % the disappears so i can play anymore plz some help me many thank bazza

    • img
      Avr 22, 2009 @ 18:58

      More InfoOK, what is it you’re updating? Are you downloading the mod from this site or when you’re trying to download the 3.1.1 patch from Blizzard?

      James

  • img
    Flinger Répondre
    Mai 7, 2009 @ 20:36

    Hellfire Horde GuideHi.
    First i would like to congratulate James for these fabulous guides. Leveled a couple of chars using them already and is swift.

    I’m leveling a DK now, so i decided to guive the addon a shot. Started doing the Hellfire guide, and it was all smooth until i fly to spinebreaker post.
    After delivering the quest, the guide gives me no more indications about the quests. It just contains the indications of the zones i should go to next.
    Not shure if that’s intended, or if the guide is unfinished, or perhaps something broken.

    • img
      Mai 7, 2009 @ 22:54

      Sounds like something funkySounds like something funky with the DK guide in particular, I’ll check it out.

  • img
    Anehum Répondre
    Mai 8, 2009 @ 0:38

    Having an issueOkay so recently I’ve been running into an issue. I can load the wow-pro guides perfectly fine on my alt mage on my main server, but recently I created a horde toon on another server and for whatever reason it won’t load the wow-pro guides. It only happens on that char, and I would really appreciate some help with this =)

    Thank you

    • img
      Mai 8, 2009 @ 0:46

      If your mains are alliance,If your mains are alliance, that means you don’t have the Horde version installed – there are two separate versions of the guide, one for Horde and one for Alliance.

      If that’s not the problem, then check and makes sure that on the new server, you have “Load out of date addons” enabled, I think it could be different preferences for different servers.

      • img
        Anehum Répondre
        Mai 8, 2009 @ 1:00

        Wow, /facepalm. I can’tWow, /facepalm. I can’t believe the solution was that simple. I seemed to have forgotten where it said Wow_pro_ALLIANCE! hah, thank you so much 🙂

        • img
          Mai 8, 2009 @ 2:06

          Haha, no prob glad it wasHaha, no prob 😉 glad it was an easy fix.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Archives