LATEST NEWS

General Bug Reporting

img
Dec
01

Known Bugs:

Before submitting a bug, please check this list to make sure you aren’t repeating a submission!

Submit Your Bug:

When submitting your addon bug, you MUST include the following:

  • The version number of your WoW-Pro installation
  • Any error text that WoW provided when your bug happened
  • Information about the guide you were using when the bug happened, including:
    • Faction (Alliance/Horde)
    • Zone
    • What step you were on
  • As many details as possible about what you were doing when the bug occurred.

Including this information will help us troubleshoot and possibly get you a temporary solution to the bug, and get it fixed as quickly as possible!

  • img
    Aug 16, 2018 @ 23:32 pm

    Re: No saving settings, and no guide list.Thanks for the report.   From the error, I am guessing that the WoWPro_Achievements addon did not get correctly installed or that there was another error that occured when you logged in.Would you mind updating to 8.0.1E and trying to reproduce it?  

  • img
    Chronicles
    Aug 12, 2018 @ 10:29 am

    No saving settings, and no guide list.Between each time I log in, the settings for wow-pro is not set. I have to redo all settings. No Display settings, no guides, nothing.Also, the last couple of time, I have this error when I try to select a guide: Date: 2018-08-12 10:25:54ID: 7Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro_GuideList.lua line 144:   Usage: WoWPro_Achievements TabFrame:SetSize(width, height)Debug:   [C]: ?   [C]: SetSize()   WoWProWoWPro_GuideList.lua:144: ActivateTab()   WoWProWoWPro_GuideList.lua:40:      WoWProWoWPro_GuideList.lua:39Locals: AddOns:  Swatter, v7.7.6000 (SwimmingSeadragon)  NPCScanOverlay, v7.3.0.1  NPCScanOverlayBroker, v1.2.7  ACP, vr259   Altoholic, vr187  AppearanceTooltip, vv18  AucAdvanced, v7.7.6000 (SwimmingSeadragon)  AucFilterBasic, v7.7.6000 (SwimmingSeadragon)  AucStatHistogram, v7.7.6000 (SwimmingSeadragon)  AucStatiLevel, v7.7.6000 (SwimmingSeadragon)  AucStatPurchased, v7.7.6000 (SwimmingSeadragon)  AucStatSimple, v7.7.6000 (SwimmingSeadragon)  AucStatStdDev, v7.7.6000 (SwimmingSeadragon)  AucUtilFixAH, v7.7.6000 (SwimmingSeadragon)  DataStore, vr65  DataStoreAchievements, vr47  DataStoreAgenda, vr28  DataStoreAuctions, vr50  DataStoreCharacters, vr42  DataStoreContainers, vr59  DataStoreCrafts, vr82  DataStoreCurrencies, vr37  DataStoreGarrisons, vr23  DataStoreInventory, vr52  DataStoreMails, vr51  DataStorePets, vr44  DataStoreQuests, vr44  DataStoreReputations, vr42  DataStoreSpells, vr32  DataStoreStats, vr31  DataStoreTalents, vr61  DBMCore, v8.0.1  DBMDefaultSkin, v  DBMLDB, v  DBMStatusBarTimers, v  Enchantrix, v7.7.6000 (SwimmingSeadragon)  EnchantrixBarker, v7.7.6000 (SwimmingSeadragon)  FBTitan, v1.0.15  FishingBuddy, v1.9.9  GTFO, v4.46.2  HandyNotes, vv1.5.2  HandyNotesArgus, v0.20.0  HandyNotesAzerothsTopTunes, vv1.2.2  HandyNotesBrokenShore, vv1.28  HandyNotesDraenorTreasures, v1.21  HandyNotesDungeonLocations, v1.35  HandyNotesFieldPhotographer, v8.0.0.0  HandyNotesHallowsEnd, vv1.3  HandyNotesHigherLearning, v8.0.0.0  HandyNotesLegionRaresTreasures, v1.1  HandyNotesLegionTreasures, v1  HandyNotesLongForgottenHippogryph, v1  HandyNotesLostAndFound, v1  HandyNotesLunarFestival, vv1.5  HandyNotesSummerFestival, vv1.5  HandyNotesTimelessIsleRareElites, v2.32  HandyNotesTimelessIsleChests, v1.19  HandyNotesWellRead, v8.0.0.0  Informant, v7.7.6000 (SwimmingSeadragon)  MasterPlanA, vA  MinimapButtonFrame, v3.1.10h  MinimapButtonFrameSkinPack, v3.0.1b  NPCScan, v8.0.1.3  Pawn, v2.2.23  Recount, vv8.0.1a  SlideBar, v7.7.6000 (SwimmingSeadragon)  Stubby, v7.7.6000 (SwimmingSeadragon)  Titan, v5.14.3.80000  TitanBag, v5.14.3.80000  TitanClock, v5.14.3.80000  TitanCurrenciesMulti, v5.29.1  TitanCurrency, v8.0  TitanGold, v5.14.3.80000  TitanLocation, v5.14.3.80000  TitanLootType, v5.14.3.80000  TitanPerformance, v5.14.3.80000  TitanQuests, v3.0.12  TitanRepair, v5.14.3.80000  TitanReputations, vv1.17  TitanVolume, v5.14.3.80000  TitanXP, v5.14.3.80000  TomeOfTeleportation, v  TomTom, vv80001-1.0.2  WoWPro, v8.0.1C  WoWProAchievements, v8.0.1C  WoWProDailies, v8.0.1C  WoWProLeveling, v8.0.1C  WowProProfession, v8.0.1C  WoWProWorldEvents, v8.0.1C  BlizRuntimeLib_enUS v8.0.1.80000 <none>  (ck=a98) Would appreciate if someone looked into it.Great addon, still love it alot! Chron

  • img
    Jul 27, 2018 @ 19:06 pm

    Re: Reporting two issues with 8.0.1BThe problems with Suramar/1 and ArcwayScenario/1 should be fixed by the update I am planning on July 29th.The second crash probably has been happening randomly when exiting any instance depending on the guide.I’ve checked in a correction. 

  • img
    Ookami.kun
    Jul 27, 2018 @ 2:27 am

    Reporting two issues with 8.0.1BReporting two issues that I found after updating to 8.0.1B.First issue mimics the last issue I reported about the quest steps/debug errors showing up in my chat pannel upon logging in or moving between instances or shards/phases. This time it’s on a smaller level with only about seven lines of code.[20:19:19] WoWPro: Step C [Down in the Depths] has a bad ¦Z¦Suramar/1¦ tag.[20:19:19] WoWPro: Step C [Hitting the Books] has a bad ¦Z¦ArcwayScenario/1¦ tag.[20:19:19] WoWPro: Step C [The Nightflow Conduit] has a bad ¦Z¦ArcwayScenario/1¦ tag.[20:19:19] WoWPro: Step C [Knock Knock] has a bad ¦Z¦ArcwayScenario/1¦ tag.[20:19:19] WoWPro: Step C [Knock Knock] has a bad ¦Z¦ArcwayScenario/1¦ tag.[20:19:19] WoWPro: Step C [Place the E.M.P.] has a bad ¦Z¦ArcwayScenario/1¦ tag.[20:19:19] WoWPro: Step C [Weather the Storm] has a bad ¦Z¦ArcwayScenario/1¦ tag. Second issue occured after I finished killing off Kil’jaeden. The error occurs after the cinematic and upon landing on the ruins in Azsura. I haven’t seen this one before, but I haven’t queued for that boss in a long while either.Date: 2018-07-26 19:32:50ID: 7Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro.lua line 72:   bad argument #3 to ‘format’ (string expected, got nil)Debug:   (tail call): ?   [C]: ?   [C]: format()   WoWProWoWPro.lua:72: Print()   WoWProWoWPro_Events.lua:390: ?()   WoWProWoWPro_Events.lua:861:      WoWProWoWPro_Events.lua:813Locals:(*temporary) = <function> defined =[C]:-1 AddOns:Thanks.

  • img
    Ookami.kun
    Jul 20, 2018 @ 3:24 am

    ThanksOh, no problem. I appreciate all the time and work you guys put into this addon. Initially I thought it was the normal update routine that occurs with the lists and such when I updated to a new version. After logging into the same character multiple times because of addon issues due to the patch, and the same info kept scrolling in the panel each time, I assumed it was something else.

  • img
    Jul 19, 2018 @ 15:30 pm

    Re: lag and texture bugIf you are using WoW-Pro on a WoLK server, you need to NOT use the latest release of WoW-Pro and TomTom.They won’t work right. I’ll see if I can dig up the right ones to use. 

  • img
    Jul 19, 2018 @ 15:27 pm

    Re: Ashenvale Quest Step ChangesThanks for the report.   I’ll add those corrections later today for the next update.At one point, Blizzard unlocked all the flight points, and we removed the discovery steps, and then had to start addding them back when they re-locked them again.We have been paying for that flip-flop for years now.Anyways, thanks!

  • img
    Jul 19, 2018 @ 15:24 pm

    Re: WoWPro quest information printing to chat panel.Sorry about that.  Those are error messages coming from the addon because it was unable to find the map for indicated zone.The next update to the addon, which will be released later today, will address this issue. 

  • img
    Ookami.kun
    Jul 19, 2018 @ 2:27 am

    WoWPro quest information printing to chat panel.After updating to 8.0.1 each time I log in the game I will get a chat box full of what looks to be WoWPro addon instructions listed. It’s a long list of steps, zones, and I assume quest names. The whole list may be longer, but this is what I was able to retieve that didn’t excede the character limit of the chat panel. This happens to each character I log in with.[20:09:05] WoWPro: ValidZone: Zone [Falanaar Tunnels@Suramar] is unknown.[20:09:05] WoWPro: Step C [Into the Crevasse] has a bad ¦Z¦Falanaar Tunnels@Suramar¦ tag.[20:09:05] WoWPro: ValidZone: Zone [Falanaar Tunnels@Suramar] is unknown.[20:09:05] WoWPro: Step T [Into the Crevasse] has a bad ¦Z¦Falanaar Tunnels@Suramar¦ tag.[20:09:05] WoWPro: ValidZone: Zone [Falanaar Tunnels@Suramar] is unknown.[20:09:05] WoWPro: Step A [The Hidden City] has a bad ¦Z¦Falanaar Tunnels@Suramar¦ tag.…[20:09:05] WoWPro: Step T [The Eye of Aman’thul] has a bad ¦Z¦Dalaran@Dalaran70¦ tag. 

  • img
    Wylel
    Jul 4, 2018 @ 7:09 am

    Ashenvale Quest Step ChangesFirst, I want to say thank you for these guides, this makes leveling much less of a headache, and in turn much more enjoyable. The first guide I did was Azshara and it went off without a hitch. Great work. But I am having some steps with the Ashenvale guide that need to be changed.1) On the step Bad News Bear-er, it states to fly to Zoram’gar Outpost, from any flightpoint. At this point there is no FM that will take you there, as you have not unlocked the FP, but the FM in Splintertree Post have a dialog that will take you to the Zoram’gar outpost (right to the FM in that outpost) and the step should tell you to go there and talk to him to get to the next step in the guide.2) The step “Zoram’gar Outpost: Hearth back to Zorom’gar Outpost”, in the steps it does not state when you get to Zorom’gar (after the previous mentioned step above) to set your hearth here. A nice addition rather than having to run or fly back (my heart was still set at Splintertree so not a huge inconvenience, but would be nice to have that added to the guide). I will continue to update if I see any further issues, and hope this helps others!

  • img
    Vouts
    Jun 23, 2018 @ 23:49 pm

    lag and texture bugsubject says all.when i turned the addons on the game started lagging after i entered world and the addons textures are bugged. Heres screen shot of bugged texture https://prnt.sc/jyjopm its near minimapaddons i have on:TomTomWoW-ProWoW-Pro AchievementsWoW-Pro DailiesWoW-Pro LevelingWoW-Pro ProfessionsWoW-Pro WorldEventsAlso im using wow wotlk 3.3.5a warmane version

  • img
    Jun 6, 2018 @ 18:03 pm

    RE:Check Box IssueI know I responded to this earlier… but apparently I didnt click save or the big bad forum monsters ate it :(But … to the issue at hand.  Basically, this would be caused by the step being associated with a quest that is part of a chain.  I think the behavior of this has changed over time with the tightening of using pre-requisite code in the guides. We probably need to review this further.Repair steps will always require manual checking off the first time, but they should remain checked off after that unless it is just before a loading screen (more on that later).  Hearth steps and setting your hearthstone steps should be detected by the guide, if they are not please provide examples in specific guides so we can try to see what is going wrong.Loading screens will cause any step that was previously marked completed for any reason other than QID (related quest completed) to become  unchecked and you will need to manually check them off upon coming out of the loading state.  Hopefully this is never more than the 1 or 2 run/portal steps immediately before.

  • img
    Jun 5, 2018 @ 1:15 am

    unable to select guideI really have no clue, I would say a bad install, but if it is consistant across multiple installs, that doesnt ring true.  You can also visit the [url=https://wow-pro.com/wiki/addon_troubleshooting_guide]WoW-Pro Leveling Addon Troubleshooting Guide[/url], where you’ll find a fix for many common issues.Checkout our discord channel and ask there.  If i’m on I will try some basic trouble shooting ideas  Its name is  WoW-Pro.  If not me, hopefully someone will be around who can assist 🙂 EDIT: I thought of something. This is pretty simple, and it may be the problem? Have you clicked on the word leveling in the tab name where it shows the guides? Sometimes (often?) it looks blank, but when you click on it then they all show. I will add a screenshot when I can, but I logged in to check and of course it didnt happen this time.

  • img
    Zippos
    May 27, 2018 @ 21:19 pm

    Can’t select any guideHey,I’ve tried to select any leveling guide but the list doesn’t show anywhere anymore.Even when I tried to install older or newer version of the addon, it didn’t work. I tried v6.2.2 / v7.3.5 / v7.3.5B / v7.3.5V, none of them allowed me to chose a leveling guide, and the “proximity detection” don’t work either.The only guide I get is level 81+ Deepholm, even tho my char is level 20+Do you have any idea what’s blocking the feature ? I had no problem a few months earlier.

  • img
    astrogirl
    Mar 28, 2018 @ 7:12 am

    Checkbox issueI’m having some trouble when I click the little check box to show I have completed a step. For example, when I click the empty checkbox next to “sell your junk and repair your armour if you need to” or “set hearthstone to this Inn if you’d like” I get a WoWPro_SkipSteps message saying that if I do that, it will skip a bunch of quests. Here is a screenshot example:  bigger version: https://i.imgur.com/bzLiYGu.pngIt doesn’t detect that I have sold anything or set my hearthstone (I don’t know if it is supposed to) and in this case I did actually set my hearthstone at the inn, so I wasn’t really trying to skip, just tick it because I did it. If I choose to cancel, then in this example, the Gadgetzan step remained on the screen until the guide seemed to catch up with me. (I’m assuming it caught up after those quests it says it will skip had been done.) Is there a way to prevent this from happening? Because its happening every single time I move to a new area and need to set my hearthstone, or am given the option to sell junk, or some other step that isn’t a quest but something I choose to do… and its quite annoying. Wow-pro version: 7.3.5A (downloaded from this site, not Twitch/Curse)

  • img
    ccwowpro
    Mar 16, 2018 @ 5:32 am

    This worked! thanks so much,This worked! thanks so much, was dying without your addon!

  • img
    Mar 12, 2018 @ 22:54 pm

    Re: since 7.3.5 WoW-Pro causing WoW to freeze LoadI’ve helped a few people with issues like this.  The problem seems to be corrupted addon state files.If the problem is on one character only, then delete the following files:<WorldOfWarcraft>WTFAccount<#>/<Realm>/<Character>/SavedVariables/WoWPro.lua*If you have a problem with all your characters, then delete the following files:<WorldOfWarcraft>WTFAccount<#>/SavedVariables/WoWPro*Hope that helps!–Ludovicus

  • img
    ccwowpro
    Mar 6, 2018 @ 18:12 pm

    since 7.3.5 WoW-Pro causing WoW to freeze Loadsince 7.3.5 WoW-Pro causing WoW to freeze on load-in screen after the character selection, always freezes at about 25% load.If I disable wow-pro, game loads fine. When in-game, if i Reload Addon WoW-Pro, interface will not /reload, freezes at 25% again.Have tried re-download and re-install, no change.

  • img
    Barleduq
    Mar 6, 2018 @ 2:48 am

    thank you *facepalm*I swear I’d gone through all the preference screens at least 3 times. Sorry to bother you. -Barleduq, slinking quietly away

  • img
    Feb 24, 2018 @ 19:51 pm

    Re: Not a bug so much as a feature requestAlready supported:In the addon options, “WoW-Pro”, “Guide Display” subsection, look for the “Minimap Button” check box and unclick! –Ludo

  • img
    Barleduq
    Feb 23, 2018 @ 6:47 am

    Not a bug so much as a feature requestor perhaps a pointer request, if this exists. Is there some way I can turn off the minimap button? My button collector finds it, so I don’t need it on the minimap, but I can’t find an option to do that anywhere in the Interface/Addons set of options. I realize this isn’t a huge request, and I don’t expect it to be done immediately, so if it takes a few revisions to get here that’s fine. I’m just seeing my minimap overloaded, so I’m trying to cut some down… 

  • img
    Feb 4, 2018 @ 16:52 pm

    Re: Hunter Order Hall – Bite of the Beast Turn-In – WaypointThanks for the tip!

  • img
    Jeremy Billones
    Jan 1, 2018 @ 16:35 pm

    Hunter Order Hall – Bite of the Beast Turn-In – WaypointStep 179 of 472First waypoint is 52.82,42.50 which is way off course.  Should probably be 32.82,42.50

  • img
    Sep 20, 2017 @ 0:45 am

    Re: WQ Pet Battle guide notification seems to be buggedThe next release (7.3.0D) will have a fix for this.It should only ask once, when the quest appears, and then not ask again while the quest is active.If you leave the area and then come back, it will reprompt, but not ask repeatedly.

  • img
    Sep 20, 2017 @ 0:37 am

    Re: Error occurring in configuration menu when changing rank.Hmm, that code does not protect against the current guide not being valid.I’ll add a fix for that.Did you see that error when you had a guide active or with the “empty” guide? 

  • img
    Sep 18, 2017 @ 9:42 am

    downloadAre you sure it’s not downloading.  Have you checked your browser’s download history?Once its downloaded, you need to copy it into your World of WarcraftInterfaceAddons directory. I’m guessing you read this since you used the same terminology of “Big Shiny Button” but just in case I will link it.https://www.wow-pro.com/addon&amp%3Bhttps://www.wow-pro.com/wiki/addon_troubleshooting_guide

  • img
    Ookami.kun
    Sep 18, 2017 @ 4:59 am

    Error occurring in configuration menu when changing rank.Version: 7.3.0CStarted leveling a character through Legion and I’m getting the following error when I go into the configuration menu and try to change the Guide DisplayRank (Difficulty/Completeness) setting. It looks to have deafualted to 2, but when I enter 3 and select OK is when the error occurs. It looks like the guide registers as 3 as it seems like I’m grabbing everything. If I reload the rank does stay at 3.Date: 2017-09-17 22:49:21ID: 2Error occured in: GlobalCount: 1Message: ..AddOnsWoWProWoWPro_Config.lua line 202:   attempt to index field ‘?’ (a nil value)Debug:   (tail call): ?   (tail call): ?   WoWProWoWPro_Config.lua:202:      WoWProWoWPro_Config.lua:201   (tail call): ?   [C]: ?   [string “safecall Dispatcher[2]”]:9:      [string “safecall Dispatcher[2]”]:5   (tail call): ?   …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:818:      …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:639   …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:870:      …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:858   (tail call): ?   [C]: ?   [string “safecall Dispatcher[3]”]:9:      [string “safecall Dispatcher[3]”]:5   (tail call): ?   …terfaceAddOnsTomTomlibsAceGUI-3.0AceGUI-3.0.lua:314: Fire()   …ListlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:70:      …ListlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:60   [C]: SetValue()   …ListlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:112:      …ListlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:100Locals:NoneAddOns:  

  • img
    Ookami.kun
    Aug 14, 2017 @ 23:11 pm

    WQ Pet Battle guide notification seems to be bugged,Wow-Pro 7.2.5APet battle guidesThis issue seems to only occur with the pet battle guides, and so far only when I come near a pet battle oponent WQ. WoW-Pro will ask if I want to open the guide for that specific oponent; fine and dandy. However, even if I select an option, whether it be Yes, No, or Don’t Ask Again, it will continuously keep asking. If I make a selection the prompt will go away for a few seconds, but eventually pop back up. If I leave it alone and don’t select any options it will keep popping up making the notification sound. Normally I could ignore the notification, but since it will open continuously prompting the notification alarm it gets annoying fast and even more so with pet battles that take a few minutes. No error occurs, just the prompt continuously opening without prompt. I thought that it might be just occuring because of the re-initialization of the addon after updaing, and that it would go away fater logging out and logging back in, but even after doing so the problem still occurs on all my characters so far. Since it seems to be limited to just the pet battle guides it’s not a big deal, but help would be appreciated since I’ve started working on the family familiar achievement. Thanks, and keep up the good work. 🙂

  • img
    Keylink 65
    Aug 14, 2017 @ 19:12 pm

    Add on downloadThis may not seem too important, but I have tried numerous times to add the game via the big shiny button. I checked the download file to be sure it did not slip past me, and yep, it’s not there. Is there any reason Wow Pro would not download, and since I am experiencing this problem, could ssomeone help me with this issue? I even let it run for over 10 minutes, and still it did not download. Thanks in advance for the help. 

  • img
    Keylink 65
    Aug 14, 2017 @ 19:11 pm

    Add on downloadThis may not seem too important, but I have tried numerous times to add the game via the big shiny button. I checked the download file to be sure it did not slip past me, and yep, it’s not there. Is there any reason Wow Pro would not download, and since I am experiencing this problem, could ssomeone help me with this issue? I even let it run for over 10 minutes, and still it did not download. Thanks in advance for the help. 

  • img
    Uenu
    May 25, 2017 @ 21:50 pm

    This, or a related bug,This, or a related bug, appears to have been around a while. I spent a few hours today, with my trusty can of raid bug spray, and have what I think is a working fix. I first had to read up on AceDB, and research other add-ons using it for profile management.

    This fix is for version [b]7.2.0B[/b], the latest available for download. I haven’t found another way to submit bug fixes, code updates.

    Open the WoWPro.lua file in your favorite text/code editor. Locate the “[b]Default profile options[/b]” section, [i]around line 276[/i]. At the end of the “defaults” dictionary, immediately after “[b]stickytitletextcolor[/b]” [i]on line 317[/i], I added the following

    [code]
    Selector = {
    QuestHard = 0,
    },
    [/code]

    Now my profile options seem to work. I haven’t noticed any issues with it yet, but i’ve only been testing it for about an hour now.

    Hope this helps, and makes it to the mainline.

  • img
    Mephistophelees
    Feb 27, 2017 @ 16:50 pm

    Hunter’s and FlightpointsNot sure how to classify this so figured I would put it as a bug.  I took the hunter order hall option to have the addtional flight points.  This has led to the addon constantly removeing and adding flight points depending on which set I’m using.  If I use my eagle flightpoints, it removes all of the normal ones and vice versa.

  • img
    ishirra
    Feb 11, 2017 @ 23:05 pm

    Wow-Pro causes my game to lagEvery 5 – 10 seconds my game seems to ‘hang’ for a split second.  When starting a fight, or trying to loot my FPS drops from 80+ to around 10-20.  When disabling WoW-Pro the problem is solved.  BugSack also gave me following error: 1x [ADDON_ACTION_BLOCKED] AddOn ‘WoWPro’ tried to call the protected function ‘WoWPro.MainFrame:Show()’.!BugGrabberBugGrabber.lua:573: in function <!BugGrabberBugGrabber.lua:573>[C]: in function `Show’WoWProWoWPro_Frames.lua:849: in function `AbleFrames’WoWProWoWPro-7.1.5.lua:390: in function <WoWProWoWPro.lua:378>(tail call): ?[C]: ?[string “safecall Dispatcher[1]”]:9: in function <[string “safecall Dispatcher[1]”]:5>(tail call): ?…ccountant_ClassicLibsAceAddon-3.0AceAddon-3.0-12.lua:558: in function <…ccountant_ClassicLibsAceAddon-3.0AceAddon-3.0.lua:551>(tail call): ?WoWProWoWPro_Frames.lua:638: in function `OnClick’…ountant_ClassicLibsLibDBIcon-1.0LibDBIcon-1.0-34.lua:116: in function <…ountant_ClassicLibsLibDBIcon-1.0LibDBIcon-1.0.lua:116>Locals:Not sure if you can do aything with this.

  • img
    Feb 1, 2017 @ 5:51 am

    To Tame the BeastI actually remember that one.  It is a small path down the hillside(pile of rocks) to where Kira is standing by the entrance to a cave.  The first point (dot) should be right at the top of the path and the 2nd point where Kira Iresoul is standing.(this comment may or may not work. I had to log out and back in to create it)

  • img
    Barleduq
    Jan 31, 2017 @ 9:04 am

    New weirdnesses, yayNot sure about calling them bugs…I had logged in and walked away, and when I walked back I decided to do some of the hunter slot, ‘taming the beast’. After all, the guide had been nudging me about it for days. “Do you want me to change to the guide with the quest Taming the Beast?”  I was doing other things, so no…  I was all the way at Illidari Stand, in Azsuna, when I figured out what guide to change it to (Hunter’s Lodge). It promptly told me that Illidari Perch was 1400+ yards in a completely weird direction – like, in the middle of Suramar. Not even in the correct direction from Illidari Stand. I went to Illidari Perch anyway, had to manually check off a couple of things (cause it complained when I wanted to skip it) and it worked fine for the rest of that quest. THe waypoints it gave me to get me from Felblaze Ingress (where it rightly told me to go) to the quest turn in were… not on the road. It was over some rocks, and I’m not sure that it was really where they were supposed to be. I can’t figure out where the Hunter’s Lodge guide is to post this there. My apologies. 

  • img
    Ookami.kun
    Jan 31, 2017 @ 3:25 am

    Error occurring with the configuration menu.When accessing the config page and trying to change the rank from 2 to 3 with 7.1.5A I get the following error:Date: 2017-01-30 21:15:25ID: 6Error occured in: GlobalCount: 2Message: ..AddOnsWoWProWoWPro_Config.lua line 202:   attempt to index field ‘?’ (a nil value)Debug:   (tail call): ?   WoWProWoWPro_Config.lua:202:      WoWProWoWPro_Config.lua:201   (tail call): ?   [C]: ?   [string “safecall Dispatcher[2]”]:9:      [string “safecall Dispatcher[2]”]:5   (tail call): ?   …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:799:      …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:614   …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:851:      …nfig-3.0AceConfigDialog-3.0AceConfigDialog-3.0.lua:839   (tail call): ?   [C]: ?   [string “safecall Dispatcher[3]”]:9:      [string “safecall Dispatcher[3]”]:5   (tail call): ?   …terfaceAddOnsTomTomlibsAceGUI-3.0AceGUI-3.0.lua:314: Fire()   …mTomlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:70:      …mTomlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:60   [C]: SetValue()   …mTomlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:112:      …mTomlibsAceGUI-3.0widgetsAceGUIWidget-Slider.lua:100Locals:NoneAddOns: Akso, out of curiosity, is the addon ever going to be configured to save the rank you set it at instead of having to always having to remember to go in and change it when I log in? Or is this a known bug, or supposed to work that way?And another possible bug: When logging in WoW-Pro likes to set my current guide always initially to Surrimar. Any way of getting it to revert back to the guide that was open and in use during the previous session?Thanks.

  • img
    BomSquad
    Jan 25, 2017 @ 19:55 pm

    Settings not saved between sessionsThis bug has been going on for quite a while now. I believe it is mentioned in the Known Bugs section of the release notes.I personally find this bug quite annoying since I have 29 toons that I am working with and even just switching toons will reset the addon settings. Every time I need to reset the difficulty, all of the font sizes and then the actual guide in use.This is the second time I have tried to respond to this post (my first attempt was about a week ago) and I need to mention that the CAPTCHA system implemented is extremely annoying. It takes be 4-5 times before it accepts my response to the CAPTCHA.

  • img
    Barleduq
    Jan 24, 2017 @ 1:30 am

    Skipping an optional boss tells me I’m gonna skip a lot of the zI’ve done most of Aszuna already – the only reason I know I haven’t is cause WoWPro is saying I’m at 397/444. (btw, does that count profession quests for professions I don’t have?)  I tried to kill Flog the Captain Eater on this toon, and gave up after dying 5 times. (I’m a bad rogue, what can I say?)  When I logged in today, WoWPro told me I have to go kill him. (Which is a great improvement over insisting I go to Suramar when I’m not yet friendly with Highmountain!)  However, when I choose to skip killing him, I get a pop up that tells me all the things that will ALSO be skipped if I skip killing Flog – at least some of which I’ve done already. For example, I know I did the Runas quest line, for example, and I recognize some of the quests mentioned in this pop up as from that line.I realize I can mark it done, but I don’t mind being reminded about it, so some day I can come back and say, oh hey, gotta kill that SOB. But this doesn’t seem like proper behavior, so I thought I’d mention. I do have the latest version named on the front page. -BarleduqETA: While standing in my order hall, I right click (manually mark this as done), and got “On to Class Halls – This ends Azsuna, and the rogue order hall guide will load.”  Which doesn’t, so I right-click, and get a box saying “Rogue order hall (112/122). Onwards.  This ends Rogue Order Hall, Azsuna is next.”  I’ll note I have a quest in my log for one of the Light’s Heart chain. I went through this cycle 5 times before coming back here to tell you about it. (yes, 5 is my usual patience limit 😀 )ETAA: I killed Flog. (had help.) It flipped to “On to Class Halls – This ends Azsuna, and the Rogue Order Hall Guide will load.”  I went back to my order hall, and it doesn’t load.  Am I doing something wrong? 

  • img
    Barleduq
    Jan 10, 2017 @ 7:39 am

    An irritating behaviorSo far today, when I have logged in: When I was in my garrison, the wowpro box had information about the uniting the zones quest, and another quest under it that I honestly can’t recall now.  When I hearthed to Dalaran, it switched to the leadin in questions, about ranks and treasures, and then asked me if I wanted to switch to the guide with the quest missing mages.  I clicked no, and manually swapped to the Azsuna guide. I logged out in aszuna (having not gotten very much farther) and it, again, gave me the suramar leadin questions. I didn’t click anything, and manually switched to the azsuna guide. Is there some way to tell it to default to the guide for the zone I’m in, if it is not complete?  I’d guess a neutral zone (Dalaran) or an older zone might be asked about… The guide is sensible enough to know that the uniting factions quest is not done. Having it continually throw suramar up is annoying.  Is there some way to have the guide list show up that doesn’t involve game menu > interface > click addons tab > scroll down > open wowpro … etc.  ? Also, this just seems odd. When in the WoW-Pro Selector pane, when I hover over the check box Enable Questing, the hover text says “Enables the guide window to be moved by clicking anywhere on it and dragging.”  I don’t understand how that description matches that name…  

  • img
    Barleduq
    Jan 10, 2017 @ 7:29 am

    More on DUpes and errorsI’m also seeing Validation Failed errors.  I note that the errors all start with WoWPro: [number here] : error type along with code gibberishThe numbers I’m seeing today are different from the numbers I was seeing yesterday. Today I’m on a hunter, running in Azsuna as my last zone to get friendly with before I hit suramar. Yesterday I was on a rogue running in Highmountain as my last zone to get friendly before I hit suramar. (I got frustrated with how much I was dying yesterday, so I’m running my hunter today)I don’t know how significant the fact that the numbers are different is. But I thought I’d mention it. -Barleduq

  • img
    BomSquad
    Jan 9, 2017 @ 22:33 pm

    Settings not saved between sessionsI have had this issue for a while now. I believe it is listed in the “known bugs” section of the release notes for several of hte recent releases.I find it quite annoying since I have 29 toons and I am constantly leveling. Having to reset these settings almost everytime I log on is quite annoying.That being said, I love this addon! I have found it invaluable for years. I would also like to point out that the CAPTCHA being used is AWFUL. I have tried to submit this port 5 times without success, failing on CAPTCHA every time.

  • img
    Barleduq
    Jan 9, 2017 @ 8:40 am

    You’ve just told me of 3You’ve just told me of 3 things I didn’t know existed in the addon – I clearly need to read for comprehension again. I’m also oblivious as to navigating this website – I can’t find the Valsharah guide.  The first waypoint for the Old Bear Trap is way the hell off base. It’s at the river, on the far side of the road to Black Rook Hold (that’s filled with undead) rather than being on the road to Bradnesburg.  I believe it should be at 46.17 , 56.14  – that’s on the correct road, and you can see the bear trap if it’s up. I completely understand about RL. If I didn’t have my own agglomeration of it hanging over my head (unhappy  medical stuff going on in my family) I’d offer to help out. 

  • img
    Dec 25, 2016 @ 19:29 pm

    Unknow and DupesYeah, that was my error…Some how those two lines got combined.. a end of line / carriage return got lost.  

  • img
    Dec 24, 2016 @ 15:56 pm

    Re: 7.1.0F Sans Legion7.1.0F definitely does have Legion in it.Try upgrading to 7.1.0G and then hitting the reset button in the control panel to repair any damaged settings.Things are not organized by expansion, so something wierd is going on.

  • img
    Dec 24, 2016 @ 15:38 pm

    RE: Unknown and Duplicate Tag errorsSorry about that.  Should be gone in release G, which I am just about to post!

  • img
    Ookami.kun
    Dec 20, 2016 @ 22:10 pm

    Unknown and Duplicate Tag errorsWith version F, when I log in or switch instances I keep getting the following text scroll in my chat panel. I assume that it’s an issue with a guide, but I was unsure which so I thought that I would post it here just in case. [16:05:55] WoWPro: 1259:Unknown tag ¦T Insurrection: Breaking the Highthold¦ in [A Insurrection: Breaking the Highthold¦QID¦45287¦PRE¦45064¦N¦Not sure if given as UI Alert? Khadgar? – 12/20¦T Insurrection: Breaking the Highthold¦QID¦45287¦M¦36.50,46.72¦N¦To First Arcanist Thalyssra. – 12/20¦].[16:05:55] WoWPro: 1259:Duplicate tag ¦QID¦ in [A Insurrection: Breaking the Highthold¦QID¦45287¦PRE¦45064¦N¦Not sure if given as UI Alert? Khadgar? – 12/20¦T Insurrection: Breaking the Highthold¦QID¦45287¦M¦36.50,46.72¦N¦To First Arcanist Thalyssra. – 12/20¦].[16:05:55] WoWPro: 1259:Duplicate tag ¦N¦ in [A Insurrection: Breaking the Highthold¦QID¦45287¦PRE¦45064¦N¦Not sure if given as UI Alert? Khadgar? – 12/20¦T Insurrection: Breaking the Highthold¦QID¦45287¦M¦36.50,46.72¦N¦To First Arcanist Thalyssra. – 12/20¦]. Thanks.

  • img
    Xaley
    Dec 16, 2016 @ 18:50 pm

    7.1.0F Sans LegionI downloaded 7.1.0F today after using 7.0.3O. The new version only goes to level 100 and does not have any legion areas in it. Not very helpful as I was disconnected from wow whilst levelling an alt and I now can’t continue using the addon as it has lost a whole expansion.

  • img
    Dec 15, 2016 @ 3:57 am

    Rogue Order Hall/Feature RequestYep yep. Im only one person. with kids and a job and such… I was late into beta as I didnt get an invite until late in July… All that means the order halls are progressing slowly.  I finished Hunter Last night *YAY* and I think I will do monk or rogue next.  Probably monk because it got substantial attention during beta and hopefully won’t need much more to finish (other than of course leveling from 100 to 110 and finishing the whole order hall campaign) but the guide itself is more developed.Once I finish those, that takes care of the 100s on my account, but I may resurrect my daughters abandoned acct and do warrior, and druid… or who knows, maybe I will level my own, afterall I never did you the lvl 90 character boost.  🙂  Pure casters Im not so good at, I do have a warlock in the 60s and a Mage in the 70sAlas, so many other distractions. Professions to max out, occasionally hanging with friends and dont forget the whole IRL Christmas thing going on 🙂 As to the comments about stormheim.  I really don’t know how one would go about fixing it.  The only thing I can think of at the moment is to turn scroll mode on so you can scroll up and see what the auto checked off steps were so you can see how the guide was leading you to that spot.  If you also check the show coords option, the coordinates from the previous step are there and you can either right click on the step text and choose map coordinates, which will briefly (30 seconds maybe?) map  that spot (and then revert back to the step you are actually on).  Another option if that is too brief is you can manually map it (assuming you are using TomTom – I expect Carbonite has a similar command, but I dont know it). Type “/way x y description” and it will put a mark on your map with the description that will help you remember why you made the mark. 

  • img
    tubera
    Dec 13, 2016 @ 16:30 pm

    Rogue Order hallI think the Rogue Order Hall campaign guide has not been completed yet. They are a lot of work and as far as I know Emmaleah is the only one working on Order hall guides.  I agree that the part of the Stormheim guide might be a bit confusing. I had trouble finding my way through the first time too. 

  • img
    Barleduq
    Dec 13, 2016 @ 14:05 pm

    This may be more of a feature request than a bugWhen I flipped to the Stormheim guide on my Rogue – the one who was chasing treasure during my last bout of bug reports – it showed me 364/472 – which talks about a basilisk.  It doesn’t say where the basilisk is, or how to get there from where I was, which was Dalaran at the time. Fortunately, I noticed I had a quest for the nasty basilisk for the Sixtrigger bros when they’re screwing the tauren, so I figure that’s the basilisk in question. I *thought* that WoWpro put a waypoint on the world / zone map, and not just the minimap, but if it does it was lost underneath the splot for the quest.In any case, I’m finding it difficult to figure out what I’m supposed to do next when I next get around to any given toon. I’m not doing this all sequentially, as I swap between alts depending on what I want to run that day, and usually park myself back in some home area, between needing to do missions for the order hall, poking my garrisons, and running a bunch of low-levels with some friends as a sort of ‘we’re tired of max content, let’s reboot’ type of thing. ETA: and so, of course, when I got close enough, it wasn’t Stonescar taht had the treasure, but another basilisk, and then I was able to find Stonescar (but got punted for maintenance, and expect to die a lot when I get to him.) Also, I hit 110 today on the rogue. While I was 109, the box said, “Rogue Order Hall, you must be 110 to continue” and after I hit 110, it said, “This is the end of the Rogue Order Hall, go to Azsuna”. Except it’s not the end of the rogue order hall, and I’ve already done azsuna. I don’t know what *should* be there, or what would be a more correct behavior. 

Leave a Reply

Your email address will not be published.

Categories

Archives